Jump to content
AIDA64 Discussion Forum
Squall Leonhart

Need some information about the Rampage III Extreme chipset / PCIE distribution

Recommended Posts

I'm just wondering how this mainboard distributes the PCI-E slots

 

the Rampage II Gene for example has 3 1x slots and a pci slot on the ICH10 while the 2 16x and 1 4x slot are on the x58

 

I assume since the R3E is utilising the Intel GB NIC integrated in the ICH, that the freed 1x slot allows it to serve the 4x slot from the ich?

 

Fiery, if you have this information it would be helpful for how i distribute my pci-e cards when i move from this Gene to the Extreme

Share this post


Link to post
Share on other sites

We don't have any deep technical specifications on that motherboard, so all we can use is the information that AIDA64 reports on the Chipset page.  Based on that, I'd say that the north bridge (X58) handles the Marvell 88SE9123 SATA3 controller and the USB 3.0 controller, both using a x1 PCIe link.  The rest of the PCIe ports of the north bridge seem to be reserved for the x16 slots, handling video adapters.  The south bridge (ICH10R) seems to only handle the JMicron JMB363 SATA2 controller, via a x1 PCIe link.  The Intel 82567V-2 Gigabit NIC seems to use PCI connection, and not PCIe, so it will not reserve any PCIe links in the chipset.

Share this post


Link to post
Share on other sites

Ok, i've got some interesting information on this.

The chipset page lists the following of a system currently running the marvel sata, jmicron sata, and nec usb 3, with a geforce 550ti and renesas usb 3 card installed in the bottom 16x slot

PCI Express Controller    
PCI-E 2.0 x2 port #1    In Use @ x1  (Marvell 88SE9123 SATA 6Gb/s Controller)
PCI-E 2.0 x2 port #2    In Use @ x1  (NEC uPD720200F1 USB 3.0 Host Controller)
PCI-E 2.0 x16 port #3    In Use @ x16  (nVIDIA GeForce GTX 550 Ti Video Adapter, nVIDIA GF116 - High Definition Audio Controller) (top most pci-e 16x 2.0 port)
PCI-E 2.0 x16 port #7    Empty

 

PCI Express Controller    
PCI-E 1.0 x1 port #1    Empty
PCI-E 1.0 x1 port #3    In Use @ x1  (Renesas uPD720201 USB 3.0 Host Controller) (bottom most pci-e 16x 2.0 port)
PCI-E 1.0 x1 port #5    In Use @ x1  (JMicron JMB363 SATA-II RAID Controller)


The location of the added usb 3 card is confirmed by device manager, which shows it running off the ich10 pci-e root port, even though it is in the bottom most 16x 2.0 slot.

 

in my present Rampage II gene setup, i have a XFI soundcard in the second 16x slot, and it is shown as operating off the x58.

I am therefore led to believe, that unless a card is placed in the 3rd pci-e 16x slot, the 4th one is not actually able to connect to the x58 root hub.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...