Jump to content
AIDA64 Discussion Forum
Arctucas

Update?

Recommended Posts

3.20.2613 BETA

 

Although I have checked 'never' in Preferences>General>NetUpdate;

 

AIDA6410-2-13.jpg

 

 

Looking at TCPView when starting AIDA64, I see this;

 

AIDA64TCPView10-2-13.jpg

 

Not exactly the best behavior...

Share this post


Link to post
Share on other sites

We've tested it, but with disabled automatic updates (that you screen shot reflects) AIDA64 doesn't perform any network traffic to our update servers.  Your screen shot shows avp.exe, and not aida64.exe, maybe that's the difference?

Share this post


Link to post
Share on other sites

avp.exe is Kaspersky Internet Security (my firewall).

 

The connection to your server only occurs when AIDA64 is opened.

 

It means avp.exe was trying to probe the AIDA64 update server.  It's not AIDA64 -- which would have the process name of aida64.exe.

 

We've checked it with TCPView, and no traffic was detected between AIDA64 main process or any other components and any internet hosts/servers when the auto-update feature is disabled in AIDA64 / main menu / File / Preferences / General.

Share this post


Link to post
Share on other sites

I see...

 

It is just that any application that connects to an internet server runs though KIS (avp.exe).

 

For example, here is a screenshot of TCPView I took while logged into my AIDA forum account to post this reply:

 

AIDA64TCPView10-6-13.jpg

 

 

Notice that firefox is not shown connected to aida64.com, but avp.exe is, as the firewall acts as a proxy.

 

But, if you are sure there is no traffic, I will trust what you say.

Share this post


Link to post
Share on other sites

Just to make sure it's not a bug in AIDA64 that is related to KIS, please let us know the KIS version+build you currently have installed.  We'll try to reproduce the issue on our test systems.

 

Please also let me know if you have the traffic to our update servers indicated by TCPView only once a day, or every time you launch AIDA64 by starting AIDA64.EXE?

Share this post


Link to post
Share on other sites

Just to make sure it's not a bug in AIDA64 that is related to KIS, please let us know the KIS version+build you currently have installed.  We'll try to reproduce the issue on our test systems.

 

Please also let me know if you have the traffic to our update servers indicated by TCPView only once a day, or every time you launch AIDA64 by starting AIDA64.EXE?

KISversion10-7-13.jpg

 

 

I only see the connection to aida64.com when I open AIDA64. It stays open for approximately 7 seconds before closing.

Share this post


Link to post
Share on other sites

We've tried it with KIS 2013, and neither TCPView or KIS built-in Network Monitor tool could register any network traffic done by AIDA64 when the auto-update feature was disabled.  Can you please check it with KIS Network Monitor as well?  And make sure to double-check if the auto-update feature is disabled in AIDA64 Preferences.

Share this post


Link to post
Share on other sites

Ah now I know what it is :)  You have the hardware monitoring item called External IP Address in use.  In order to detect your external IP address, AIDA64 needs to ping an internet server that sends the external IP address back to AIDA64.  We use our auto-update server for that purpose as well.  It's a similar service that others provide at e.g. http://whatismyipaddress.com/  or http://www.whatsmyip.org/

 

If you prefer AIDA64 not to communicate with any internet servers, then you need to disable the External IP Address hardware monitoring item.

Share this post


Link to post
Share on other sites

Ah now I know what it is :)  You have the hardware monitoring item called External IP Address in use.  In order to detect your external IP address, AIDA64 needs to ping an internet server that sends the external IP address back to AIDA64.  We use our auto-update server for that purpose as well.  It's a similar service that others provide at e.g. http://whatismyipaddress.com/  or http://www.whatsmyip.org/

 

If you prefer AIDA64 not to communicate with any internet servers, then you need to disable the External IP Address hardware monitoring item.

As usual, you have it exactly right.

 

I did not even remember I had enabled that option.

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...