Jump to content
AIDA64 Discussion Forum
gbohn

Aida64 losing GPU sensor inputs

Recommended Posts

Hi;

 

  I just upgraded my graphics card from an Asus GTX 670 OC (Direct CU II) to an Asus GTX 780 OC Direct CU II (GTX780-DC2OC-3GD5). This is under Windows 7 64-Bit.

 

  When I first brought up Aida64, I saw sensor entries for various GPU items. After a reboot, some of these entries seem to have disappeared and are no longer seen or logged. (I still see the other entries for GPU MHZ, GPU fan speed, etc. though).

 

  Specifically, the sensor values for these entries no longer appear anywhere I can see:

 

        GPU VRM (Watts)

        GPU VRM (Amps)

        GPU +12V (Volts)

        GPU VRM V (Volts)

        GPU VRM (Degrees C)

 

  When they were recorded, they seemed to have had plausible values.

 

  I was running Aida64 Extreme 4.00.2700 when I first saw this. I updated to Beta 4.00.2746 to see if this would help. The missing values came back, but are gone again after the next reboot.

 

  So, is there any way to get these entries to come back and stay? Or should they never have shown up in the first place?

 

   This is on an Asus Rampage Formula III motherboard. The entries don't seem to show up under Computer/Sensor or in the log.

 

  I am attaching a summary with and without these values shown.

 

   Thanks;

 

 

R3F_2014-01-18_23-47-58_stat.htm

R3F_2014-01-19_11-41-56_stat.htm

Share this post


Link to post
Share on other sites

We believe that such anomalies are caused by certain odd behavior of the ForceWare drivers.  We've already implemented workarounds for that, but it may not work 100% sometimes.  What version of ForceWare are you using?  And what exactly do you have to do to get the values back?

Share this post


Link to post
Share on other sites

I'm running the 332.21 WHQL drivers.

 

  Originally I noticed that re-installing AIDA64 seemed to bring the values back, but then they would dissapear for some reason after a while. I was beginning to suspect that maybe this had to do with the system being hot or cold, but now I'm not so sure.

 

  I have AIDA64 set to 'Load AIDA64 at WIndows startup'. Yesterday I manually exited Aida64, and launched it explicitly as Administrator to see if that helped. It seemed to, as the values came back.

 

  At the moment, they are still showing up. So, I guess I'll have to run it some more and see if this permanantly fixed the problem or not.

 

  I'll update and let you know.

 

  Thanks;

Share this post


Link to post
Share on other sites

Then I guess the problem is due to you are running AIDA64 as a normal user, instead of running it with administrator privileges.  Many low-level features of AIDA64 requires administrator rights to function properly.

Share this post


Link to post
Share on other sites

So, if that's the case, is there a way to have Aida64 run as Administrator when 'Load at Windows startup' is selected?

 

 I'm using the load at startup feature because I have an Aquero 5 and its software (also started on login) is reading some sensor values from Aida64 (I can't remember if this is through WMI or 'Shared memory').

 

 For what it's worth, I have rebooted my system, so Aida64 started automatically when I logged on and I'm currently seeing all the sensor values. I'll have to see if it stays that way.

Share this post


Link to post
Share on other sites

So, if that's the case, is there a way to have Aida64 run as Administrator when 'Load at Windows startup' is selected?

 

 

There's no specific way to enforce that from AIDA64.  It will automatically use the Windows user under which AIDA64 was executed.  If it doesn't suit your needs, then you may want to copy the scheduled task in Task Scheduler under a different name, alter it to suit your needs, and disable the Load at Windows startup option in AIDA64.

Share this post


Link to post
Share on other sites

Let me preface this by saying I am a driver, I do not get under the hood, so technically speaking I am a noob :).

 

That being said, I saw this option couple days ago when I was poking around and thought I would share in case it is useful:

 

Right click on Aida64.exe (not a link),

at the bottom of the options listed should be "Properties"... click it,

select the "Compatibility" tab,

at the bottom is an option "Run this program as an administrator"

 

No idea if this is useful, and I have Win8.1/64, but maybe it's available with Win7/64.

 

Edit: attachments deleted

Share this post


Link to post
Share on other sites

As a follow-up, things have continued to work better. So whatever the issue was initially, it seems to all be working as expected now.

 

  The account I log in as has Administrator status, but sometimes I've seen that programs still do something extra that triggers a UAC prompt. In my case, I was letting Aida64 get auto-launched (and it wasn't asking for elevated permissions). Just to see if it made a difference, I explicitly manually launched it with 'Run as Administrator'.

 

  This seems to have sorted things out, but I guess that could have been coincidental with Windows itself sorting something out.

 

  At any rate, letting it auto-launch (without anything special)  at log-in seems to be working for me now and I'm seeing all the sensors (knock on wood...).

 

  I'm currently running the 4.00.2752 Beta.

Share this post


Link to post
Share on other sites

There's no specific way to enforce that from AIDA64.  It will automatically use the Windows user under which AIDA64 was executed.  If it doesn't suit your needs, then you may want to copy the scheduled task in Task Scheduler under a different name, alter it to suit your needs, and disable the Load at Windows startup option in AIDA64.

 

wait.. what?

 

Aida64 should always request permission to launch as it requires elevation (Task Scheduler being the only way to silence the uac prompt)

Share this post


Link to post
Share on other sites

If you start AIDA64 as a standard user (not an administrator), then no UAC prompt will be displayed, and AIDA64 will run in limited mode, since it has no access to its low-level features.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...