Jump to content
AIDA64 Discussion Forum
bbent67888

List index out of bounds (5)

Recommended Posts

Annoying bug that happens every now and then when I right click AIDA64 in the tray and Open AIDA64. This errors pops up and the program does not open.

Right clicking the tray icon again shows Hide Main Window instead now. If I click that, nothing happens, but now it will show as Open AIDA64 again, and this time it will open without errors.

What's the cause of this? I have a hunch that maybe the window state was saved with hardware selected that has since been removed from the PC, and it tries to focus it in the list again, but errors since it's not there. You need to do some list bounds checking!

Error.png

Share this post


Link to post
Share on other sites
12 hours ago, bbent67888 said:

Annoying bug that happens every now and then when I right click AIDA64 in the tray and Open AIDA64. This errors pops up and the program does not open.

Right clicking the tray icon again shows Hide Main Window instead now. If I click that, nothing happens, but now it will show as Open AIDA64 again, and this time it will open without errors.

What's the cause of this? I have a hunch that maybe the window state was saved with hardware selected that has since been removed from the PC, and it tries to focus it in the list again, but errors since it's not there. You need to do some list bounds checking!

We've tried to reproduce the issue, but it doesn't come up on our test systems.

Do you have any hardware monitoring modules (Sensor Icons, OSD Panel, Desktop Gadget, SensorPanel, LCD, External Applications, Logging, Alerting) enabled?

What is the AIDA64 page or feature that you have last showing before you hid the AIDA64 main window?

Share this post


Link to post
Share on other sites
4 hours ago, Fiery said:

We've tried to reproduce the issue, but it doesn't come up on our test systems.

Do you have any hardware monitoring modules (Sensor Icons, OSD Panel, Desktop Gadget, SensorPanel, LCD, External Applications, Logging, Alerting) enabled?

What is the AIDA64 page or feature that you have last showing before you hid the AIDA64 main window?

I use SensorPanel.

I'm not sure what I have selected.. I've never paid attention to what I was doing before the error pops up. (It's usually a few days later when I need to open the window again). Any tips on where that error comes from so I can try to reliably reproduce on my side?

Share this post


Link to post
Share on other sites
21 hours ago, bbent67888 said:

I use SensorPanel.

I'm not sure what I have selected.. I've never paid attention to what I was doing before the error pops up. (It's usually a few days later when I need to open the window again). Any tips on where that error comes from so I can try to reliably reproduce on my side?

Since you've mentioned a hardware that you may have removed meanwhile... Do you frequently plug/unplug USB devices for example?  If yes, then please try to plug/unplug it once or twice, and check if you can open the AIDA64 main window.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×