Jump to content
AIDA64 Discussion Forum
cricketbones

OSD Alignment Issues

Recommended Posts

I have wanted this option for so long and I tried it in the new beta, yet using any alignment aside from 'left' causes the OSD to constantly jitter and shift as the info changes. 

Share this post


Link to post
Share on other sites
2 hours ago, cricketbones said:

I have wanted this option for so long and I tried it in the new beta, yet using any alignment aside from 'left' causes the OSD to constantly jitter and shift as the info changes. 

Is it because the width of the OSD panel keeps changing?  It should change with left alignment too, BTW.

Share this post


Link to post
Share on other sites
On 10/10/2019 at 7:23 AM, Fiery said:

Is it because the width of the OSD panel keeps changing?  It should change with left alignment too, BTW.

Of course the info changes, but when it is left aligned, the whole OSD doesn't shift.  I have a bunch of info all left aligned on the left side of my second monitor, which is to my right. 

 

I made it right aligned and put it to the right side of that monitor and the whole column shifts any time there is info changing. It isn't something that happens the other way..

 

Maybe over explaining it...i don't have any capture software installed or I would make a little vid. Perhaps a phone cap would be useful if all of this still sounds goofy. 

Share this post


Link to post
Share on other sites
On ‎10‎/‎12‎/‎2019 at 2:43 AM, cricketbones said:

Of course the info changes, but when it is left aligned, the whole OSD doesn't shift.  I have a bunch of info all left aligned on the left side of my second monitor, which is to my right. 

I made it right aligned and put it to the right side of that monitor and the whole column shifts any time there is info changing. It isn't something that happens the other way..

Maybe over explaining it...i don't have any capture software installed or I would make a little vid. Perhaps a phone cap would be useful if all of this still sounds goofy. 

I think I know what you mean, so no need to hassle with making and uploading a video of the anomaly.  I'm thinking about a proper way to get around this issue.  The problem is that the OSD Panel is top-left anchored, so when the width changes its top-left corner stays in place and the width increases (or shrinks).  It's great when you use left alignment, but can produce jerkiness when the OSD content is right-aligned.  We can either let you specify a minimum width for the panel, but then you need to tweak around the find the right width to accomodate all possible text widths as the values keep changing; or make the OSD Panel top-right anchored so its width would increase and shrink on the left border of the panel.  Since the latter would require less of a hassle and tweaking on your part, IMHO that should be the way to go.  Let us think about it and make a few test runs before coming up with a proper fix.

Share this post


Link to post
Share on other sites
22 hours ago, cricketbones said:

The newest beta works perfectly. Amazeballz.

Awesome ;) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...