Jump to content
AIDA64 Discussion Forum
Snakeyes

registration key

Recommended Posts

I just downloaded the latest version of the software. It requested a registration key. I entered the key provided to me by AIDA64 (one-year extension) and it was rejected. I then tried my old Everest key that actually extends for a longer-term and that too was rejected. Help

Share this post


Link to post
Share on other sites

Please try to download the latest beta version of AIDA64 Extreme Edition, and try it with that too:

http://www.aida64.com/downloads/aida64extremebuild1158cbv3slyk8nzip

In case that still doesn't accept your key, then please send an email to our Sales Department:

upgrade AT aida64.com (replace AT with @)

BTW, make sure to download the right edition of AIDA64. If you had a key for EVEREST Ultimate Edition that you exchanged for an AIDA64 key, then you need to use AIDA64 Extreme Edition, and not AIDA64 Business Edition.

Also make sure to have the right date configured on your system. Sometimes (e.g. after a system crash, or after a bad overclocking try, etc) the date may reset to e.g. January 01, 2008. You have to make sure you have the right date set in Windows before you can enter the key in AIDA64.

Thanks,

Fiery

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×