Jump to content
AIDA64 Discussion Forum
hsm06

fixed: AIDA64 v2.50.2042 BSoD with Intel RSTe v3.2.0.1135 WHQL RAID driver

Recommended Posts

I have the same problem with the newest version 3.2.0.1135, but when i disable "Raid member enumeration" under Preferences/Stability everything works fine and the BSOD is gone.

Greetings

Share this post


Link to post
Share on other sites

We're already working on it. I'll post a new AIDA64 beta download link into this topic once the bug is fixed. It should be ready later today or tomorrow.

Share this post


Link to post
Share on other sites

We're currently testing the fix with all RST and RSTe driver releases we've got, and the results are so far promising :) It will fix all issues reported so far, both slowdowns and BSoDs.

Share this post


Link to post
Share on other sites

I've been experiencing some Blue Screens (storport.sys, etc.) w/ AIDA 64 (both v2.60.2139 and prior builds) and Intel RSTE 3.5. Any idea why this would be? What's the issue with RSTE and AIDA64?

Thanks.

Share this post


Link to post
Share on other sites

I've been experiencing some Blue Screens (storport.sys, etc.) w/ AIDA 64 (both v2.60.2139 and prior builds) and Intel RSTE 3.5. Any idea why this would be? What's the issue with RSTE and AIDA64?

Thanks.

We've already fixed a BSoD issue in AIDA64 v2.60. Maybe there's a new one related to RSTe 3.5? Do you use the WHQL release of RSTe 3.5?

Share this post


Link to post
Share on other sites

I too have been experiencing blue screens and it seems to be due to aida64. Have used a64 for a long time but just updated my computer and since then I get usually 1 blue screen crash per day and the log points to iastora.sys. I have tried removing the Intel RST drivers and still got the same blue screen errors. I am now running the RST 3.5.0.1092 drivers (cause the intel ssd toolbox doesn't work properly without them) Since I saw a thread about a64 I decided to turn it off and have since had no blue screens. I am currently running a64 again and have turned off low level smart operations in the stability options to see if that makes any difference. Attached are the windows minidumps and the aida system report. I will report back when I have more data.

Thanks

Minidump.zip

A64 Report.zip

Share this post


Link to post
Share on other sites

Thank you. Does it mean you don't get BSoD only if you uninstall SSD ToolBox application?

BTW, to assure AIDA64 doesn't go through Intel RST/RSTe drivers to get RAID member drives data, you need to disable both RAID options in AIDA64 / main menu / File / Preferences / Stability. That should make AIDA64 fully stable, even with SSD ToolBox running.

Share this post


Link to post
Share on other sites

No it means I don't get a crash if I don't run Aida64. SSD toolbox has nothing to do with it seems to be more related to RST and aida as I was getting them without SSD toolbox installed. I had another crash last night I have disabled the two raid options you mentioned in stability. Will let you know if that works thanks:)

Share this post


Link to post
Share on other sites

I too have been experiencing blue screens and it seems to be due to aida64. Have used a64 for a long time but just updated my computer and since then I get usually 1 blue screen crash per day and the log points to iastora.sys. I have tried removing the Intel RST drivers and still got the same blue screen errors. I am now running the RST 3.5.0.1092 drivers (cause the intel ssd toolbox doesn't work properly without them) Since I saw a thread about a64 I decided to turn it off and have since had no blue screens. I am currently running a64 again and have turned off low level smart operations in the stability options to see if that makes any difference. Attached are the windows minidumps and the aida system report. I will report back when I have more data.

Thanks

Same RST version, same issue.

Every times after the system running for a long time (about 5hrs), I've got BSOD with the error code:D1.

My SSD is Plextor M5 Pro, not Intel, so there is no any kind SSD toolbox or something like it running background.

BTW, the both RAID options in Preferences / Stability are disabled.

Share this post


Link to post
Share on other sites

Same RST version, same issue.

Every times after the system running for a long time (about 5hrs), I've got BSOD with the error code:D1.

My SSD is Plextor M5 Pro, not Intel, so there is no any kind SSD toolbox or something like it running background.

BTW, the both RAID options in Preferences / Stability are disabled.

When both RAID options are disabled, AIDA64 will use standard Windows API calls to detect ATA devices and to acquire SMART attributes list incl. disk temperature (if available). It means, if that causes a BSoD, it is caused by the storage controller driver, so it should be the fault of Intel RSTe drivers rather than AIDA64's.

Share this post


Link to post
Share on other sites

When both RAID options are disabled, AIDA64 will use standard Windows API calls to detect ATA devices and to acquire SMART attributes list incl. disk temperature (if available). It means, if that causes a BSoD, it is caused by the storage controller driver, so it should be the fault of Intel RSTe drivers rather than AIDA64's.

Thanks for reply.

But without AIDA64 running in the background, the BSOD won't happen.

Share this post


Link to post
Share on other sites

Thanks for reply.

But without AIDA64 running in the background, the BSOD won't happen.

Because in such case no calls are made for the ATA layer of Intel RSTe drivers. But the bug is still in the RSTe drivers.

Share this post


Link to post
Share on other sites

Because in such case no calls are made for the ATA layer of Intel RSTe drivers. But the bug is still in the RSTe drivers.

OK.

And is there any solution before Intel fix this bug? I don't want to give up both AIDA64 and RST.

Share this post


Link to post
Share on other sites

Since it's quite hard to debug this issue (due to the BSoD takes at least several hours typically to come up), the best way is to try downgrading to an older RSTe release, in a hope that they're more stable...

Share this post


Link to post
Share on other sites

Since it's quite hard to debug this issue (due to the BSoD takes at least several hours typically to come up), the best way is to try downgrading to an older RSTe release, in a hope that they're more stable...

Really appreciate your reply.

I'll try an older RST version.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...