Jump to content

Waveshare 8.8 IPS Side Monitor


Recommended Posts

Topic not specific to Aida64 but I know a lot of people on this forum use this monitor or other waveshare monitors for their sensor panels.

I am using the 8.8 monitor for my sensor panel, however I am having an issue where the monitor only displays a black screen on startup. To get an image on the monitor I have to unplug the USB cable and plug it back in. This is also occurs when the monitor turns off after an hour of inactivity (computer doesn't go to sleep, just monitor turns off). I bring the main monitor back up, but waveshare stays black.

On startup and a black screen, I can see that NVIDIA, Device Manager and Windows all recognise that the monitor is plugged in and working. Multiple displays I can see the monitor, just can not get anything to appear.

Actions taken so far:

- Replaced all provided cables with new ones (HDMI and USB-C)

- Tried multiple USB ports

- I have reset the graphics drivers

- All drivers are up to date (BIOS, Windows, GPU etc)

- Uninstalled and reinstalled drivers

- Waveshare have my issue on their website and how to resolve. Done these steps a number of times, no luck

- Waveshare support provided me with new firmware for monitor that would fix. Did not fix. Waveshare have since gone silent.

- Adjust power management. USB power always on

Plan is for this monitor to install inside my case, but can't while I can't get it to automatically turn on. Can't not find any information online about this issue.

Any one else had this issue or similar? Where does everyone else plug their monitors into eg internal USB with adapter or external? Powered USB hub?

Any help or advice would be great, starting to get frustrated with this.

Link to comment
Share on other sites

  • 4 weeks later...
  • 7 months later...
  • 1 month later...

The OP's provided firmware fix worked for me here in December of 2023. Thank you!! Beware that Win11 blocked me from running the utility, but you can click "more info" in the dialog and run it anyway. Follow the directions in the Readme that accompanies the executable and hopefully you will also have success. Thank you, SithHellscream, for doing the digging on this. Been annoying me for months and I was beginning to worry I was going to wear out the USB-C port on the unit with constant replugging of the cable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...