Jump to content

[Solved] New external SSD not showing in Gadget items


Recommended Posts

Hello all, 

In my Win 10 computer, I have three internal hard drives and an external one.

I use AIDA64 desktop gadget support to monitor the temperatures of my hard drives (among other things). It works very well.

I recently replaced my old WD external hard drive for a new SanDisk external SSD (on the same USB port).

The new SSD seems to be well recognized by Aida, but it doesn't appear in the "Gadget items" list (in the Aida preferences). Nor does appear in the desktop gadget.
The desktop gadget (and the "Gadget items" list) do show my three internal hard drives, but not the new external SSD.

I reiterate that it worked fine with my previous external hard drive plugged into the same USB port. I could see 4 hard drives in all.

In the AIDA interface, I can see the new external SSD, but it doesn't appear as a Gadget item.

Do you have any idea how I can get AIDA to add it to the "Gadget items" list?

Thanks to all.

Translated with DeepL

Link to comment
Share on other sites


I've made some progress since yesterday.

My external SSD (SanDisk Extreme) has no SMART data. This certainly explains why Aida doesn't see it in the temperature settings.

In addition, the SSD does not appear in the UEFI.

I don't think Aida64 can do anything about it.

Thanks anyway for your thoughts,

Link to comment
Share on other sites

  • THTH changed the title to [Solved] New external SSD not showing in Gadget items

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...