Jump to content

Aquacomputer sensor issues


TheGoatee
 Share

Recommended Posts

I have just migrated from a Goverlay and I am loving the software. I am however having two issues reading the sensors on my USB aquacomputer D5 pump.

Issue 1)
 
I can only get the temperature probe reading from the aquasuite software to work. The other two readings Pump Power and Speed Signal don't seem to be available. These are the readings I am after from aquasuite.


Aquasuite_readings.png


Issue 2)
 
This is my current Sensor Panel, its fine apart from the temperature probe will occasional (once every 10 seconds) lose signal. 

WT_ok.png


When that happens I get the following:

WT_not_ok.png


Any ideas?

Link to comment
Share on other sites

And here is the Dump from aquacompuer:

 

------[ AIDA64 Extreme v5.20.3400 ]------
 
------[ Microsoft Windows 8.1 6.3.9600.17668 (64-bit) ]------
 
------[ Motherboard Info ]------
 
Motherboard ID      : 63-0100-000001-00101111-122413-Chipset$A1126151_BIOS DATE: 07/14/14 19:37:27 VER: 04.06.05
Motherboard Model   : ASRock Z97M OC Formula
Motherboard Chipset : Intel Wildcat Point Z97, Intel Haswell
 
DMI MB Manufacturer : ASRock
DMI MB Product      : Z97M OC Formula
DMI MB Version      : 
DMI MB Serial       : E80-46018500071
DMI SYS Manufacturer: To Be Filled By O.E.M.
DMI SYS Product     : To Be Filled By O.E.M.
DMI SYS Version     : To Be Filled By O.E.M.
DMI SYS Serial      : To Be Filled By O.E.M.
DMI BIOS Version    : P1.60
 
 
------[ DevClass / Human Interface Devices ]------
 
<DESC>HID-compliant vendor-defined device</DESC><DEVPATH>\\?\hid#vid_0c70&pid_f003#6&199bacdf&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_0C70&PID_F003\6&199BACDF&0&0000</INSTANCE><BUSNUM>00000003</BUSNUM><ADDR>00000008</ADDR>
<DESC>HID-compliant mouse</DESC><DEVPATH>\\?\hid#vid_0461&pid_4d80#6&18b884f2&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_0461&PID_4D80\6&18B884F2&0&0000</INSTANCE><BUSNUM>00000002</BUSNUM><ADDR>00000009</ADDR>
<DESC>HID-compliant game controller</DESC><DEVPATH>\\?\hid#vid_045e&pid_028e&ig_00#7&1c403c70&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_045E&PID_028E&IG_00\7&1C403C70&0&0000</INSTANCE><BUSNUM>00000000</BUSNUM><ADDR></ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_2516&pid_9494&mi_03#7&3841e0f0&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_2516&PID_9494&MI_03\7&3841E0F0&0&0000</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000011</ADDR>
 
------[ HID Device Info / HID-compliant vendor-defined device ]------
 
Manufacturer              : Aqua Computer
Product                   : MPS
Device ID                 : 0C70-F003
Usage                     : 0001h
Usage Page                : FF00h
Input Report Byte Length  : 0
Output Report Byte Length : 0
Feature Report Byte Length: 214
 
------[ Aquaero/Aquaduct Device ]------
 
Manufacturer               = Aqua Computer
Product                    = MPS
Device ID                  = 0C70-F003
Usage                      = 0001h
Usage Page                 = FF00h
Input Report Byte Length   = 0
Output Report Byte Length  = 0
Feature Report Byte Length = 214
 
------[ MPS Feature Report ]------
 
Data Version         = 4
Firmware Version     = 1008
Bootloader Version   = 1001
Hardware Version     = 1100
Pressure Sensor Type = 0
 
0000  04 00 F0 03  E9 03 4C 04  93 0B 06 6C  A5 1C E2 30  ......L....l...0
0010  7C 02 9E 02  FF 03 79 02  56 FE CF 00  00 00 00 00  |.....y.V.......
0020  FF 7F 00 00  00 00 00 00  2D 0A 28 09  FF 7F 21 00  ........-.(...!.
0030  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0040  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0050  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0060  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0070  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0080  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0090  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00A0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00B0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00C0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00D0  00 00 00 00  00                                     .....

Link to comment
Share on other sites

I'm sorry for the late response.

1) We'll add the pump RPM reading in the next AIDA64 beta update. I'm afraid we have no information on how to read the pump power value. We have a theory about which register may be used for that, but we would need a bit more data to verify our theory. Can you please post two different Aquaero Dumps, made at different pump power settings, like 40% and 60% or so? For both dumps please indicate the actual pump power value set, and also the pump power value as shown in Aquasuite. Thank you in advance!

2) It may be due to a temporary USB HID communication issue, or due to a collision between Aquasuite and AIDA64. Please try to close Aquasuite, and check if it makes it any better.

Thanks,

Fiery

Link to comment
Share on other sites

1) No problem,

 

30% set (29.7% in aquasuite readout)

Output Report Byte Length : 0
Feature Report Byte Length: 214
 
------[ Aquaero/Aquaduct Device ]------
 
Manufacturer               = Aqua Computer
Product                    = MPS
Device ID                  = 0C70-F003
Usage                      = 0001h
Usage Page                 = FF00h
Input Report Byte Length   = 0
Output Report Byte Length  = 0
Feature Report Byte Length = 214
 
------[ MPS Feature Report ]------
 
Data Version         = 4
Firmware Version     = 1008
Bootloader Version   = 1001
Hardware Version     = 1100
Pressure Sensor Type = 0
 
0000  04 00 F0 03  E9 03 4C 04  93 0B 06 6C  A5 1C E2 30  ......L....l...0
0010  8F 02 B3 02  FF 03 8F 02  56 FE E5 00  00 00 00 00  ........V.......
0020  FF 7F 00 00  00 00 00 00  DF 07 43 08  FF 7F 09 00  ..........C.....
0030  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0040  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0050  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0060  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0070  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0080  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0090  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00A0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00B0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00C0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00D0  00 00 00 00  00                                     .....

 
45% set (45.1% in aquasuite readout)

Feature Report Byte Length: 214
 
------[ Aquaero/Aquaduct Device ]------
 
Manufacturer               = Aqua Computer
Product                    = MPS
Device ID                  = 0C70-F003
Usage                      = 0001h
Usage Page                 = FF00h
Input Report Byte Length   = 0
Output Report Byte Length  = 0
Feature Report Byte Length = 214
 
------[ MPS Feature Report ]------
 
Data Version         = 4
Firmware Version     = 1008
Bootloader Version   = 1001
Hardware Version     = 1100
Pressure Sensor Type = 0
 
0000  04 00 F0 03  E9 03 4C 04  93 0B 06 6C  A5 1C E2 30  ......L....l...0
0010  8D 02 B1 02  FF 03 8D 02  56 FE E3 00  00 00 00 00  ........V.......
0020  FF 7F 00 00  00 00 00 00  87 0A 58 08  FF 7F 22 00  ..........X...".
0030  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0040  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0050  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0060  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0070  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0080  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0090  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00A0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00B0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00C0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00D0  00 00 00 00  00           

 
60% set (59.8% in aquasuite readout)

Output Report Byte Length : 0
Feature Report Byte Length: 214
 
------[ Aquaero/Aquaduct Device ]------
 
Manufacturer               = Aqua Computer
Product                    = MPS
Device ID                  = 0C70-F003
Usage                      = 0001h
Usage Page                 = FF00h
Input Report Byte Length   = 0
Output Report Byte Length  = 0
Feature Report Byte Length = 214
 
------[ MPS Feature Report ]------
 
Data Version         = 4
Firmware Version     = 1008
Bootloader Version   = 1001
Hardware Version     = 1100
Pressure Sensor Type = 0
 
0000  04 00 F0 03  E9 03 4C 04  93 0B 06 6C  A5 1C E2 30  ......L....l...0
0010  8C 02 AF 02  FF 03 8B 02  56 FE E1 00  00 00 00 00  ........V.......
0020  FF 7F 00 00  00 00 00 00  02 0D 6E 08  FF 7F 3B 00  ..........n...;.
0030  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0040  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0050  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0060  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0070  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0080  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
0090  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00A0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00B0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00C0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00D0  00 00 00 00  00                                     .....

 

2) I now have aquasuite closed and the data exports disables and it seems to resolve the issue, 

Link to comment
Share on other sites

Thank you for the feedback and the test runs. I'm afraid we cannot find the right register to use to measure pump power :( We have some candidates, but the numbers do not add up for some reason. Maybe the pump power is not scaled in a linear fashion or so. We'll keep looking, but at this time I cannot promise anything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...