Jump to content
AIDA64 Discussion Forum
Guest Mark

[semi-solved] AIDA EE v1.70.1431 Beta Issue /w new Marvell 91xx SATA 6G Driver

Recommended Posts

Guest Mark

Hello,

today i updated my onboard Marvell 91xx Ahci/Raid Controller drivers (ASUS P8P67 EVO REV 3) to the newest version 1.2.0.1002

the drivers can be found at the bottom under

Marvell MV-91xx (88SE91xx) Ahci/Raid Controller

(PCI\VEN_1B4B&DEV_90xx&CC_ & PCI\VEN_1B4B&DEV_91xx&CC_)

Drivers Version 1.2.00.1002 & 1.1.0.6 WHQL New 07/03/11

@ http://www.station-drivers.com/page/marvell.htm

After that, the 2 hard drives connected to that controller are not recognized anymore, which results in lack of support using the windows sidebar feature to read out hdd temperatures. i guess this is not really a bug, but AIDA needs an update to recognize the drives again?

with the old drivers from the motherboard download page it worked fine. (v1.0.0.1045)

i am using windows 7 enterprise SP1 x64 german edition

regards

Share this post


Link to post
Share on other sites

Are your 2 drives in a RAID array, or they're standalone drives?

Thanks,

Fiery

Share this post


Link to post
Share on other sites
Guest Mark

Are your 2 drives in a RAID array, or they're standalone drives?

Thanks,

Fiery

standalone

regards

Share this post


Link to post
Share on other sites

Thank you. Please right-click on the bottom status bar of AIDA64 main window --> Disk Debug --> RAID Dump. Copy-paste the full results into this topic.

Then right-click on the bottom status bar of AIDA64 main window --> Disk Debug --> Disk Controllers Dump. Copy-paste the full results into this topic.

Thanks,

Fiery

Share this post


Link to post
Share on other sites
Guest Mark

------[ AIDA64 v1.70.1431 Beta ]------

------[ Microsoft Windows 7 Enterprise 6.1.7601 (64-bit) ]------

------[ Motherboard Info ]------

Motherboard ID : 63-0100-000001-00101111-020510-Chipset$0AAAA000_BIOS DATE: 02/05/10 19:13:52 VER: 08.00.10

Motherboard Model : Asus P8P67 Evo

Motherboard Chipset : Intel Cougar Point P67, Intel Sandy Bridge

DMI MB Manufacturer : ASUSTeK Computer INC.

DMI MB Product : P8P67 EVO

DMI MB Version : Rev 1.xx

DMI MB Serial : MT7013K44804267

DMI SYS Manufacturer: System manufacturer

DMI SYS Product : System Product Name

DMI SYS Version : System Version

DMI SYS Serial : System Serial Number

DMI BIOS Version : 1606

------[ Disk Controllers ]------

Controller #0 = \Device\Scsi\JRAID1 (Driver = JRAID)

Controller #1 = \Device\Ide\IdePort0

Controller #2 = \Device\Ide\IdePort1

Controller #3 = \Device\Ide\IdePort2

Controller #4 = \Device\Ide\IdePort3

Controller #5 = \Device\RaidPort0 (Driver = adpu320)

Controller #6 = \Device\RaidPort1 (Driver = mvs91xx)

Controller #7 = \Device\mcdbus (Driver = mcdbus)

------[ Physical Drives @ Controller ]------

PHYSICALDRIVE0 is at Controller #1 (\Device\Ide\IdePort0)

PHYSICALDRIVE1 is at Controller #1 (\Device\Ide\IdePort0)

PHYSICALDRIVE2 is at Controller #2 (\Device\Ide\IdePort1)

PHYSICALDRIVE3 is at Controller #4 (\Device\Ide\IdePort3)

PHYSICALDRIVE4 is at Controller #5 (\Device\RaidPort0)

PHYSICALDRIVE5 is at Controller #5 (\Device\RaidPort0)

PHYSICALDRIVE6 is at Controller #5 (\Device\RaidPort0)

PHYSICALDRIVE7 is at Controller #6 (\Device\RaidPort1)

PHYSICALDRIVE8 is at Controller #6 (\Device\RaidPort1)

Share this post


Link to post
Share on other sites

Thank you. We'll do some test runs with both Marvell driver packages on a 88SE91xx controller. Once we have an AIDA64 release with the explained issue fixed, I'll report back in this topic. But please provide us at least a week, since currently we're very busy preparing for the next major update for AIDA64.

Thanks,

Fiery

Share this post


Link to post
Share on other sites

Thank you. We've tried to tweak it a bit in v1.80.1450, but apparently it didn't work out. We've also done some test runs on a 88SE91xx controller, but it seems our test motherboard is not affected by the issue you experience on your system. We'll try to get another motherboard with a Marvell controller, and hopefully it will be suitable to replicate the issue.

Share this post


Link to post
Share on other sites

BTW, do you have the option RAID SMART support enabled in AIDA64 / main menu / File / Preferences / Stability? You may need that to enable AIDA64 to recognize the drives you have connected to a RAID controller.

Share this post


Link to post
Share on other sites
Guest Mark

BTW, do you have the option RAID SMART support enabled in AIDA64 / main menu / File / Preferences / Stability? You may need that to enable AIDA64 to recognize the drives you have connected to a RAID controller.

wow, that fixed it. it was deactivated. however, with former drivers it worked without activating it, so i don't know if this shouldn't be adressed either way?

thanks for now

Share this post


Link to post
Share on other sites

Thanks for the feedback. It seems, lately RAID controller manufacturers are revamping their drivers to make them work in RAID mode even when only standalone drives are connected. Or, at least the drivers stop providing the usual Windows API interfaces for standalone drives enumeration. Hence you need to activate RAID SMART support with those drivers to let AIDA64 scan RAID controllers using RAID methods either.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...