Jump to content
AIDA64 Discussion Forum
codrutp

AIDA64 Extreme crashes with BSOD IRQL_NOT_LESS_OR_EQUAL (old Intel RAID drivers)

Recommended Posts

I am new to this program. I have just tried it and purchased it. So far starting AIDA64 caused my laptop to crash 3 times with a blue screen and code IRQL_NOT_LESS_OR_EQUAL

Any idea if this is a bug? My laptop it's not usually crashing and generally it's very stable.

Share this post


Link to post
Share on other sites

After analyzing the dump files it appears that the crash was caused by:

Probably caused by : iaStorAVC.sys ( iaStorAVC!Wcdl::Allocator::freeContiguous+20 )
So not AIDA64 related. I'll investigate that in parallel.

 

Share this post


Link to post
Share on other sites
6 hours ago, codrutp said:

After analyzing the dump files it appears that the crash was caused by:

Probably caused by : iaStorAVC.sys ( iaStorAVC!Wcdl::Allocator::freeContiguous+20 )
So not AIDA64 related. I'll investigate that in parallel.

 

It is most likely because your notebook has an old Intel RST RAID drivers installed, and the driver gets confused by the RAID enumeration commands that AIDA64 issues.  You can however disable the RAID enumeration if you don't have any RAID arrays defined in your system by going to the AIDA64 installation folder and editing the file called AIDA64.INI.  Try to find the following 2 lines in it (by using e.g. Notepad):

LowLevelRAIDEnum=1
LowLevelRAIDSMART=1

And modify those lines to make them look like this:

LowLevelRAIDEnum=0
LowLevelRAIDSMART=0

If you don't have an AIDA64.INI in there, then create a new one (a text file) and put the following lines in the file:

[Generic]
LowLevelRAIDEnum=0
LowLevelRAIDSMART=0

Share this post


Link to post
Share on other sites

Thanks. Indeed I might have been using some old drivers because I didn't installed any driver than what Microsoft Windows updated itself.

I have now had to reinstall Windows and I switched from RAID to AHCI in BIOS and indeed the system now is stable. AIDA64 is running just fine with the default settings.

Thank you!

Share this post


Link to post
Share on other sites
4 hours ago, 6zayn said:

I have updated to the latest drivers. Still the problem exists. Any suggestions please?

Try to disable RAID features as I've explained above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×