Jump to content

Huge performance drop in AIDA64 Memory&Cache Benchmark after Hyper-V was enabled in Windows 11


Recommended Posts

I got an Intel NUC8i7HVK (or known as Hades Canyon).

It came with an Intel i7 8809G CPU running at 4.5GHz (overclocked), 16GB*2 DDR4-3200 CL19 (overclocked).

I recently updated my system to Windows 11 and enabled the Hyper-V function which was required by Windows Subsystem for Android (WSA).

Then I found that the CPU and RAM speed was wrongly recognized by AIDA64. It reported that the CPU was running at around 1100MHz and RAM clock was about 600MHz (but Windows task manager still reported correct clock speed).

When running the Memory&Cache Benchmark, I could only managed to get about 6xxxMB/s read speed, 8xxxMB/s write speed and 7xxxMB/s copy speed, and the memory latency was high up to more than 380ns. The CPU cache speed was also much slower than it should be.

I tried to restore BIOS settings to default but with no help. As soon as I have disabled Hyper-V function in Windows Control Panel, AIDA64 could detect correct clock speed, and benchmark results were also back to normal.

I have another PC laptop which is based on AMD platform (5900HS, 40GB DDR4-3200). When Hyper-V was enabled and WSA installed on this PC, no any familiar issue occurred at all.

So I was confused, who is to be blamed for this issue? Microsoft, or Intel? Or it was just a bug from AIDA64?

Link to comment
Share on other sites

32 minutes ago, nfsking2 said:

I got an Intel NUC8i7HVK (or known as Hades Canyon).

It came with an Intel i7 8809G CPU running at 4.5GHz (overclocked), 16GB*2 DDR4-3200 CL19 (overclocked).

I recently updated my system to Windows 11 and enabled the Hyper-V function which was required by Windows Subsystem for Android (WSA).

Then I found that the CPU and RAM speed was wrongly recognized by AIDA64. It reported that the CPU was running at around 1100MHz and RAM clock was about 600MHz (but Windows task manager still reported correct clock speed).

When running the Memory&Cache Benchmark, I could only managed to get about 6xxxMB/s read speed, 8xxxMB/s write speed and 7xxxMB/s copy speed, and the memory latency was high up to more than 380ns. The CPU cache speed was also much slower than it should be.

I tried to restore BIOS settings to default but with no help. As soon as I have disabled Hyper-V function in Windows Control Panel, AIDA64 could detect correct clock speed, and benchmark results were also back to normal.

I have another PC laptop which is based on AMD platform (5900HS, 40GB DDR4-3200). When Hyper-V was enabled and WSA installed on this PC, no any familiar issue occurred at all.

So I was confused, who is to be blamed for this issue? Microsoft, or Intel? Or it was just a bug from AIDA64?

On certain Intel processors, before the Ice Lake and Rocket Lake era, suffer from this issue under Windows 11.  You need to disable Memory Integrity to get proper BCLK and CPU core clock measurement, as well as accurate benchmark results.  Even Intel's own tool (XTU) suffers from major issues under Windows 11, so it's definitely not a bug in AIDA64 but a serious limitation that Microsoft introduced in Windows 11.  One that causes headaches to both Intel and us.

AMD processors do not suffer such limitations under Windows 11, but there used to be other problems about them under Windows 11 that Microsoft resolved by now.

Link to comment
Share on other sites

1 hour ago, Fiery said:

On certain Intel processors, before the Ice Lake and Rocket Lake era, suffer from this issue under Windows 11.  You need to disable Memory Integrity to get proper BCLK and CPU core clock measurement, as well as accurate benchmark results.  Even Intel's own tool (XTU) suffers from major issues under Windows 11, so it's definitely not a bug in AIDA64 but a serious limitation that Microsoft introduced in Windows 11.  One that causes headaches to both Intel and us.

AMD processors do not suffer such limitations under Windows 11, but there used to be other problems about them under Windows 11 that Microsoft resolved by now.

Thanks for your reply Fiery!

I have checked Memory Integrity setting in Windows Defender and it was disabled, but the problem still existed.

And the problems you mentioned on AMD processors, I think you meant high L3 latency which had been fixed by Microsoft recently?

Link to comment
Share on other sites

39 minutes ago, nfsking2 said:

Thanks for your reply Fiery!

I have checked Memory Integrity setting in Windows Defender and it was disabled, but the problem still existed.

And the problems you mentioned on AMD processors, I think you meant high L3 latency which had been fixed by Microsoft recently?

I probably should have stated that you need to have any virtualization and sandboxing disabled.  So under Win11 you need to disable both Memory Integrity and Hyper-V.

The high L3 latency issue should have been fixed already.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...