Jump to content

FPU Problems (Core i7-960)


Recommended Posts

Hi there,

Hopefully this is the right forum to post in. This is a two part post describing initial conditions, and then first attempt to solve my problem.

Initial Conditions:

I’m trying to trouble shoot my computer that contracted the siref virus a month ago. Ultimately I formatted and did a clean re-installation of Windows 7. Since doing that though my system can’t handle much of a load and will restart if overloaded. Keep in my that besides having a weird virus the computer was running okay prior to this. At least with the small loads of work it typically receives.

Specs: i7 processor, 960 @ 3.2 Ghz, no overclocking, 12 GB RAM, 64 Bit Win 7, EVGA Nvidia GeForce 450, 2TB Hitachi HDD (system is roughly 1.5 years old)

I don’t game. I primarily run a Java based stock trading program, surf the web, and run some fairly basic mapping software, and Microsoft Office. I have had the mapping software crash it. One thing that will instantly crash it now is if I try to get a Windows Experience Index rating. I have read about some various issues with NVidia drivers really messing with cards (even to the point of ruining the actual card) and what not. I decided to disable my Nvidia driver and run the WEI again, this time it made it past 5% and then simply stopped and said it could not do the video portion of the test. This made sense and lead me to believe that something is up with my GPU. I then proceeded to get the AIDA 64 software so that I could do some stability testing. What I’ve found is that everything tests fine except FPU and GPU, when I run these individually, my computer instantly restarts, so I really can’t even log it.

My motherboard temps run 41. My core temps run in the 50’s and then can get into the upper 70’s (have seen 81-82 on one before) when under max load during the CPU stability test.

First attempt to solve problem:

I decided to wipe windows again and see if the problem persisted. WEI would run before I installed, the EVGA 450 this time. After I installed it though, WEI would crash. So I made up my mind that my graphics card was at least partially the problem and I went to best buy and bought a EVGA GT 610. A decent card for my uses. Bring it home, install, etc. Run WEI no problem and get a rating of 4.1, the graphics card being the lowest score as expected. My processor and memory score 7.6’s and drive is a 5.9. So I proceed to run the AIDA stress tests, and this time it passes it does not shut off when I run GPU or FPU separately. I figure, problem solved and am happy, and continue to use the computer just fine for a number of hours.

This morning I wake up to check the market, and I grab the mouse. Computer wakes up, but nothing comes onto the screen. Notice my wireless dual band USB adapter is not lit. I have to do hard restart. Computer flashes windows resuming, and then nothing. After a couple of hard restarts I choose the 2nd option that says something about wiping the restoration data. This allows windows to restart. It is then apparent that I have some kind of unrecognized USB port errors. This is all quite random to me. I decided to run AIDA again, and the computer instantly restarts. I am probably leaving out some steps, but upon one of the new restarts for whatever reason the computer is back to recognizing my USB ports and devices that are plugged into them. I run WEI to see if that fails the system, and it runs fine. I run GPU on AIDA and no instant crash, but when I run FPU I get the instant restart again.

So in summary I thought I fixed the problem with the new graphics card as the computer would pass the FPU and GPU tests, but now it is failing the FPU test again, but not the GPU. Is my problem two fold or are the cards degrading my system? I’m kind of at a loss. My next thought is motherboard or bad configuration of drivers, bios settings etc. Don’t understand why it passed FPU last night though. I apologize for the long posts, but details matter when trying to pinpoint a problem. As a side note temps seem fine. If anything they lowered a little bit after blowing out the computer and installing the new graphics card. Only seeing low 70’s on core temps during max load, and motherboard and HDD stay cool.

One other question…I see a lot of fan RPM’s reported in the 3000+ RPM range. I’ve never seen mine get above 1500 RPM, but maybe my system doesn’t get loaded enough to ramp up and now if it did it shuts off before I ever see higher fan RPM’s.

Any advice would be appreciated.

Thanks,

Conrad

Link to comment
Share on other sites

I understand your frustration about the issues about your computer. It looks like a classic case of PSU (Power Supply Unit) failure. With the new graphics card I guess it worked better because GT610 draws a lot less power than GTS450, especially when the GPU is under heavy load (e.g. GPU stress test in AIDA64 SST - System Stability Test). When you run AIDA64 SST, the most demanding task for most computers is the FPU subtest. It makes the processor to work at full clocks, utilizing Turbo Boost (if supported), and every floating-point processing units are driven to excessive load. It effectively means while running the FPU test your processor will draw the most power through the PSU it is possible. When you enable the GPU subtest on top of the FPU subtest, your GPU is also driven to full load, and so the power draw increases even more. A weak PSU may fail at either the FPU or the GPU subtest, but most definitely cannot stand FPU+GPU subtests combined.

Of course, I may be wrong about the PSU issue, so if you have a chance to borrow a reliable PSU from a friend, it may be the best way to further diagnose this issue. There's a slim chance the memory modules are failing, or the motherboard has some weak capacitors, or some other hardware or software flaws occur. But if I had to bet some cash on which component is it, I'd put my money on your PSU ;)

I hope this helps. Please let us know about your progress on resolving this issue.

Regards,

Fiery

PS: Don't worry about the fan RPMs. As long as the bottom Throtting graph in AIDA64 SST stays at 0% while running the FPU subtest, your processor is not overheating. While 80 Celsius is quite high, it's not the first thing you need to take care of. First make sure to resolve the restarts and lockups, then you can step on to putting the heat down a bit ;)

Link to comment
Share on other sites

Thanks for the quick reply and help. I picked up a Corsair GS 800 on my way home for lunch. First I wanted to check for faulty capacitors, try a couple more stress tests etc. Capacitors good, stress tests, actually initially ran FPU for 2 minutes. Came back and tried it again and instant restart.

Installed new Corsair GS 800, everything started up nice. Ran CPU stress test, and temps stayed in the 60's. Improvement. Ran GPU no problem. Ran FPU no problem. So I decided to run the combo FPU/GPU, and it DID NOT instant restart! So, so far so good and going to say problem solved for now and hopefully for good. All in a lunch breaks' work!

Thanks again for the help,

Conrad

PS: Going to keep the new GT 610 graphics card since it pulls less power. This is a good thing and it was on sale.

PPS: FWIW, my original PSU looks to be generic as I probably tried to save money when I spec'd the computer out upon ordering. Could be a case of it pays to buy name brand stuff at times. I also live in NM and it's dusty as heck here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...