Jump to content

Main monitor on DisplayPort, small monitor for SensorPanel on HDMI - Messes windows sizes up after wake from sleep/restart


Recommended Posts

Hello,

Been really struggling with this issue and I have not found a solution.

I have my main monitor (Samsung Odyssey G9 5120x1440) on DisplayPort to my 3080 GPU, and then I got a few different size HDMI monitors to use as the HUD for SensorPanel. Some of the HDMI monitors are small 4.3" (800x480), and some are as large as 10.4" (1280x800), but largely they all cause the same issue.

Every time the computer turns off the monitors when I am away from the computer for 30 mins or so (screensaver essentially), and it wakes up, the HDMI monitor seems to come alive first, so the desktop jumps to that and it messes up all the Window sizes and icon positions etc. When my main monitor comes alive a few moments later, everything jumps back to it, but the windows have shrunk, icons have moved position etc. SensorPanel resumes on the small HDMI monitor no problem, but its whats left on the main monitor that is really driving me bonkers.

Is there a solution to this?

I have already seen things about the registry edit you do in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\
And deleting out all old monitor entries, and adjusting the SIMULATION entry etc with the main monitor parameters, but it has not solved the problem.

Given SensorPanel is AIDA64 I can only assume this is widely seen by users on here.

Can someone shed some light please on how this gets resolved? I am sick of my desktop and windows getting screwed up every time I resume working on the computer or start the PC up again.

Thanks

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I was having something similar with my 3080. Anytime the screens went to sleep, or loading a full screen game, other monitors seemed to do their own thing.  I would also get funky stuff when importing different (correct sized) sensor panels.

 

Goto where your Aida64 .exe is.  Right Click > Properties > Compatibility Tab > 'Change High DPI settings' > Check 'Override High DPI Scaling' Scaling performed by: 'System' (from the drop down) > Ok/Apply > Restart. 

 

Also, try putting your sensor panels etc, on the LEFT side of your main monitor in the windows display settings. I've read where they are can mess with what panels get what on wake up. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...