Jump to content
AIDA64 Discussion Forum
HachAdmin

Aida-Batch-Start is ignoring arguments

Recommended Posts

I'm running Aida from a shared folder by using a batch file.

This is the command line start \\Server\Shares\aida64.exe /ACCEPTBG /R /DATABASE /AUDIT /SAFE /SILENT

But whe the user is signed in the program starts normal, visible for the user and all other arguments are ignored.

This happens on several different workstations with WinXP, Win7, Windows Server 2008 R2.

This is a domain network and I have entered a registry entry for the startup.bat on all workstations over a GPO.

Firewall is disabled by GPO and when I manually start the program from it's share it will run as supposed.

Can anyone help?

Share this post


Link to post
Share on other sites

Are you sure you use AIDA64 Business Edition? Please note that AIDA64 Extreme Edition doesn't support command-line based automation, hence it ignores any command-line arguments.

Regards,

Fiery

Share this post


Link to post
Share on other sites

I'm sure. And it works works with the arguments but not when I start the program while a user is loggin in.

And btw, using the task planer is working as well.

I'm thinking about using the /delay <seconds> argument.

But it is strange.

Share this post


Link to post
Share on other sites

Make sure to disable any other methods of auto-launching AIDA64 at Windows startup. AIDA64 itself supports that (in main menu / File / Preferences / General / Load AIDA64 at Windows startup); and then there's Windows Task Scheduler. Maybe multiple methods are active, and they interfere with each other.

Share this post


Link to post
Share on other sites

Thanks for the suggestion and I had this option enabled but disabling it didn't change anything.

In the mean whil I tried a couple of more ways to run the program. Also the task planer runs the program only without the arguments.

These are my used arguments "/R /DELAY 60 \\FS01\Aidareports\$HOSTNAME /CSV /AUDIT /HW /SAFE /SILENT"

Share this post


Link to post
Share on other sites

That command-line looks slightly incorrect. You need to specify the filename right after /R, with only a space character between them. Also, you cannot mix /AUDIT and /HW, you need to use only one of them. So your fixed command-line would look like this:

/R \\FS01\Aidareports\$HOSTNAME /CSV /AUDIT /SAFE /SILENT /DELAY 60

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×