Jump to content

Cannot connect to MySQL Database


Recommended Posts

I am trying to setup database connection to MySQL server using MySQL ODBC driver that i downloaded from mysql web site. What should I put into "Data source". When I leave it blank I get an error "Data source name not found and no default driver specified". In "Driver" I choose MySQL ODBC 5.2w Driver. Provider is set to MySQL (MSDASQL). The only option that gives me successful connection is dBase Files, but in this case Database Manager shows no data, although there is data in the database, and I see no connection attempts using tcpdump on the server where mysql DB server resides.

Link to comment
Share on other sites

For MySQL you need to select the MySQL ODBC driver in the Driver drop-down list, enter your Database name, enter your Server address (hostname or IP address), and enter your credentials (User + Password).  If you fill in all those fields, you can leave the Data source field empty.

 


Regards,

Fiery

Link to comment
Share on other sites

  • 1 year later...

Hello!
Whether it is planned to use in AIDA64 Business Edition MySQL Connection not through ODBC, and through the only library (C ++ Driver for MySQL (Connector/C ++) or C Driver for MySQL (Connector/C))?
To use ODBC on each personal computer in the domain - it isn't really good, in view of excess and unnecessary libraries when it is possible to use only one.

Link to comment
Share on other sites

It is a pity.
Alas, I don't know programming languages, but some projects use the only dynamic library libmysql.dll, and the settings are specified in the project.
There is a nuance that libmysql.dll has to be the same version as the server, but it is a smaller problem, than to establish on each MySQL Connector/ODBC personal computer.

I ask to excuse if something not so, I want to make your program more universal and simple.

Link to comment
Share on other sites

  • 2 months later...

I put this on the parameters /R /CSV /AUDIT /SAFE Help me with that, thank you.

In case you want to push your reports into a SQL database, then you need to remove /CSV from your command-line, and add /DATABASE instead.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...