Jump to content
AIDA64 Discussion Forum
delevic

How to setup remote control trugh WAN

Recommended Posts

Hi, 

 

I am trying to to create connection between two  computers via WAN. So in router settings I make adress reservation for remote computer, which is 192.168.1.100, and I created virtual server for that address with service port  5001. Then I tried to acsess via remote control on wan address  wan:5001 , but get some errors. Then I changed in Aida preferences remote control port from 2348 to 5001, and still get error. So , what to do next ?

 

Best Regards

Delevic

Share this post


Link to post
Share on other sites

Please verify if both the local computer and the remote computer has the same TCP/IP port configured for remote control in AIDA64 Preferences.

 

Also verify that the remote computer has accepting incoming connections enabled via e.g. /ACCEPT or /ACCEPTBG command-line option, or via AIDA64 / main menu / Remote / Accept Incoming Remote Connections.

 

 

Regards,

Fiery

Share this post


Link to post
Share on other sites

I made bat file with /accept command. That is ok. They have same port 5001. But they have different wan address. The both computers are connected on Internet via router.  

Share this post


Link to post
Share on other sites

Different WAN address is not a problem, it should work fine in your scenario as long as the port forwarding is properly configured, and the remote computer has its firewall port open.

Share this post


Link to post
Share on other sites

Port forwarding is ok. Wake on Lan works . Now on other computer I got this:

 

Screen_Shot272.jpg

 

Screen_Shot273.jpg

 

Osd panel works :)

 

Whet I start aida on aida.exe everything is normal. 

Share this post


Link to post
Share on other sites

Make sure to configure a different port for each remote feature of AIDA64.  You cannot use the same port on all features.

Share this post


Link to post
Share on other sites

Yes, I made mistake , two ports has the same number . Finally , I get it works. The problem was in router...After restarting the router, everything is as it should be :)  Thanks

Share this post


Link to post
Share on other sites

Exactly under what circumstances did you get those messages?  Did you connect via Remote Control?  If yes, then what did you do when you had those error messages come up?  Do you use AIDA64 v4.20? (latest version)

Share this post


Link to post
Share on other sites

Yes I am using 4.20.28 Under normal circumstances, not remote control. While I am working on the computer suddenly I get a error message.   I didn't have this errors with Aida extreme.  

Share this post


Link to post
Share on other sites

Please upgrade to the latest stable or beta version of AIDA64 Business v4.30.  We've done a few tweakings to the Windows Devices enumeration module that may also fix the issues you're experiencing.

Share this post


Link to post
Share on other sites

Hi again after long time :)

I am using aida remote constantly via wan. The problem is , when i enter ip adress and port of remote pc xxx.xxx.xxx.xxx:5001 , Aida automatically added service port form preferences of pc that I use. So I get IP:5001:5005 and that wont work. So  every time when I need to remotely control another computer, I have to change remote port in preferences (I need to enter port number of remote computer that I need to control). Is there some easier way ?

Regards 

Delevic

Share this post


Link to post
Share on other sites
4 hours ago, delevic said:

Hi again after long time :)

I am using aida remote constantly via wan. The problem is , when i enter ip adress and port of remote pc xxx.xxx.xxx.xxx:5001 , Aida automatically added service port form preferences of pc that I use. So I get IP:5001:5005 and that wont work. So  every time when I need to remotely control another computer, I have to change remote port in preferences (I need to enter port number of remote computer that I need to control). Is there some easier way ?

Regards 

Delevic

In order to clarify the nature of the issue: you are using AIDA64 Business, and you go to main menu / Remote / Remote Control, you enter the IP address along with the port number of your choosing, press OK?  Is it the place where you would need AIDA64 to handle the port address selection in a smarter fashion? ;)

Share this post


Link to post
Share on other sites
16 hours ago, Fiery said:

In order to clarify the nature of the issue: you are using AIDA64 Business, and you go to main menu / Remote / Remote Control, you enter the IP address along with the port number of your choosing, press OK?  Is it the place where you would need AIDA64 to handle the port address selection in a smarter fashion? ;)

Yes, I go to main menu / Remote / Remote Control and I entered IP adress with port number. The problem is that Aida in background add remote control port form preferences/Remote features. That is ok if we use remote control in LAN environment where we use local IP addresses for each computer without port forwarding.

Quote

Is it the place where you would need AIDA64 to handle the port address selection in a smarter fashion? ;)

 Yes :) It would be nice if AIDA64  automatically use the port that I enter next to the ip address only for that session. And the port in preferences  remain as a port for future access to that specific computer.

 

 

ScreenShot323.jpg

ScreenShot324.jpg

Share this post


Link to post
Share on other sites
On ‎2017‎. ‎04‎. ‎29‎. at 8:47 AM, delevic said:

Yes, I go to main menu / Remote / Remote Control and I entered IP adress with port number. The problem is that Aida in background add remote control port form preferences/Remote features. That is ok if we use remote control in LAN environment where we use local IP addresses for each computer without port forwarding.

 Yes :) It would be nice if AIDA64  automatically use the port that I enter next to the ip address only for that session. And the port in preferences  remain as a port for future access to that specific computer.

I've just sent you a private message about this issue ;)

Share this post


Link to post
Share on other sites

Hi Tamas,

Well done. Works like a charm!

As always, this is the best and most efficient technical support ever. 

Best regards to you and your whole AIDA64 team, 

Delevic

Share this post


Link to post
Share on other sites
On ‎2017‎. ‎05‎. ‎02‎. at 0:37 PM, delevic said:

Hi Tamas,

Well done. Works like a charm!

As always, this is the best and most efficient technical support ever. 

Best regards to you and your whole AIDA64 team, 

Delevic

Thank you for your feedback and your kind words ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×