Jump to content

Fixed: Aida64 not starting with Windows 10 after upgrade


Recommended Posts

There are few software programs I don't care to live without. One of them is Aida64 Extreme. I've been using it for the 20 years they've been around. Happy Anniversary! and here's to 20 more. cheers.


After a recent upgrade to W10 x64 Pro from 8.1 Pro, Aida64 was no longer starting with windows automatically as I prefer. If this is you I have a fix.

I tried many things to fix it, like uninstall> reinstall Aida64 Extreme, UN-tick the preference from Aida64 preferences dialog> then restart the tick it again and restart, adding it to the startup folder through RUN. shell:startup, disabling and re-enabling through the task manager, disabling all startup programs one at a time and all at once, disabling all AV & Internet security  and finally uninstall Aida64 Extreme> registry clean (CCleaner)> restart> reinstall but still not luck. Oh and I searched this forum as well which brings me to the fix.


It's a registry hack but very easy to do just make sure to backup your registry before you start so you can restore it if things go wrong.


1.  Tap the windows key and type “regedit†glance at the results to make sure the “regedit.exe†is highlighted and click enter if not left click it and the registry editor will start.


2.  or Hold the windows key+R and bring up the run dialog box and type in "regedit" and hit enter whichever way you prefer is fine.


3. Before you click on anything or expand any dialog, click on “File†then “Export†and save a copy of your registry to a folder you will remember. This will be a full backup of your entire registry. I recommend making a new backup before making any changes in the future as well. Or just backup the key you are changing but you get the point.


4. Now Navigate to this registry key location:




4.  Right click on the right side of the panel and select>  “New String†value and that will create a new string value that you name whatever you like but I used  "Aida64 Extreme†click enter to create the string


5.  Now Double click your new string value or right click it and under where it says "value data" type in the dialog box the location of “aida64.exeâ€. 


The default location should be:


"C:\Program Files (x86)\FinalWire\AIDA64 Extreme\aida64.exe†(without the quotes of course) and click enter once again to complete.


6. Before you close the registry to complete the process it’s time to add another best practice step to the process. Click on Favorites and name this location RUN or whatever but so you’ll recognize it. This works the same way a browser does. Every time you open the registry editor the location you just edited will be readily available at any point down the road. Once done close the editor.


7.  That's it!  You're done.  Now you can restart your PC to see that Aid64 Extreme now starts up automatically with Windows 10!


GL and I hope this helps keep someone from formatting and reloading to fix this problem which would have been my next step had this not worked.


It should be noted I had no issues with a clean install of Windows 10 with Aida64 Extreme and this procedure should not be needed if that’s you.

Link to comment
Share on other sites

Thank you for the info. However, under Windows Vista and later operating systems, the Run Registry key is not supposed to be used, since it may interfere with UAC. It's best to clean that Registry path from AIDA64 entries (if there's any), then clean whatever AIDA64 related entries you can find in Task Scheduler (the built-in tool of Windows Vista+), and then enable the Load AIDA64 at Windows startup option in AIDA64 / main menu / File / Preferences / General. In case that way AIDA64 cannot be auto-started at bootup, then it's usually because the security software installed prevents it from running. Then you need to alter the configuration of your security software ;)



Link to comment
Share on other sites

With all due respect I tried exactly what you suggested 1st with no success I still could not get Adia64 Ex to start with windows. Currently I'm experimenting with not disabling UAC which I had done in the past since Vista immediately to avoid the hassel. It seems Windows has improved the interface because I have not been overly annoyed by it with either the upgraded version and my clean install version moreover I have not gotten the exceptions you refer to with Adia64 Ex enabled through registry and starting with windows. Eventually I will clean install W10 on this device but I offered this as a viable known working solution for those upgrading to W10 and the same issue as I. As always YMMV



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...