Jump to content

Problem with AIDA64 with admin rights and the sidebar gadget


Recommended Posts


i recently bought AIDA64 (used everest ultimate until last week) and i have some problems with the gadget:

1. at first where do i get the gadget for AIDA64 is it the same everest used? Do i have to download it somewhere first?

2. i never got the windows vista sidebar gadget running for everest, because:

2.1: everest (and i think AIDA64 too) HAS to run with admin rights for full functionality! (with normal rights some sensors are not shown/working)

2.2: i definitely canot disable the windows UAC, because i need it, the UAC was the only reason for me to go from windows XP to windows vista

2.3: but the gadget works when starting everest (AIDA64) with normal user rights or when loging in with a full admin account (because in this case, even the gadget has admin rights and i found out that both programms have to be started with the same rights to communicate)! But that is not what i want. I want to log in as normal user, start AIDA64 with admin rights and use the gadget!

The problem is that i cannot run the gadget with admin rights, i think that would be the solution, or finding a way to let AIDA64 with admin right, comunicate with the gadget with normal rights.

3. How do all the other users manage to get everest/AIDA64 running with the gadget?

Link to comment
Share on other sites

1) AIDA64 has the gadget in its distribution package. It is the file named AIDA_VSB.VSB. As soon as you enable the Sidebar feature in AIDA64 (main menu / File / Preferences / Hardware Monitoring / Vista Sidebar), then the gadget files are copied to the relevant Sidebar folder on your computer. After that, all you have to do is manually add the gadget to your Sidebar or Desktop.

2.1) It is a limitation that no Windows software can get around. You simply need to have admin rights to communicate with sensor devices.

2.3) Have you tried to run AIDA64 by right-clicking on the AIDA64.EXE file (or the AIDA64 shortcut on your Desktop) --> Run as administrator?



Link to comment
Share on other sites

2.3) Have you tried to run AIDA64 by right-clicking on the AIDA64.EXE file (or the AIDA64 shortcut on your Desktop) --> Run as administrator?

Thanks, and yes i allways start AIDA64 with admin rights (rightclick) because, as you stated above, else i would not be able to use some of the sensors. But the problem is, that admin AIDA64 cannot work with NOADMIN gadget! Only the following combinations work:

1. AIDA64 withou admit rights + gadget (started as normal user)

2. login as admin: AIDA64 + gadget (in this case both tools have admin rights, because i logged in as admin)

the problem is, i only work as normal user! i have no problem starting AIDA64 with admin rights (right click) but it seems to be not possible to start any gadget with admin rights! i have read somewhere about a workaround: startin the whole sidebar as admin (but this has to be done over the task scheduler and causes other problems because this way all gadget are working with admin rights).

i simply need a way to get ADIA64 (with admin rights) comunicate with the normal gadget.

EDIT: i have added a sreenshot of the situation:

- aida64 is running with admin rights (as you can see because all of the sensors are shown)

- gadged is startet but cannot find aida64 working

post-60-034477400 1287790448_thumb.jpg

Link to comment
Share on other sites

Thank you for the clarification, now I understand the problem you're facing. We'll do some test runs to reproduce the issue, and I hope I'll be able to get back to you (in this topic) with a solution next week.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...