Jump to content

AMD EPYC and ASRockRack EPYCD8-2T Problems


Crashtest
 Share

Recommended Posts

AIDA64 incl. v6.25.5400 has some problems with my EPYC system:

 

- wrong identification of EPYC integrated XHCI

- no access to IPMI onboard

- no sensor data (FANs)

- no DIMM data

 

System:

AMD EPYC 7251

ASRockRack EPYCD8-2T/Rev 2 (BIOS P2.50)

Windows 20H1 (19041.172)

 

 

Problem 1:

PCI Database problem - PCI\VEN_1022&DEV_145F is shown as "AMD K17 - Reserved" but it's the EPYC integrated XHCI

 

 

Problem 2:

The ASRockRack EPYC8D-2T(Rev 2) has onbaord IPMI based on ASPEED AST2500 but AIDA64 cant get any data from it

 

Problem 3:

AIDA64 wont display any FAN data from the sensor chip

 

Problem 4:

AIDA64 cant read DIMM Data (SPD)

bug_dimms.png

bug_dimms2.png

bug_fans.png

bug_ipmi.png

bug_usb.png

epyc.txt

Link to comment
Share on other sites

On 4/12/2020 at 5:39 PM, Crashtest said:

AIDA64 incl. v6.25.5400 has some problems with my EPYC system:

- wrong identification of EPYC integrated XHCI

- no access to IPMI onboard

- no sensor data (FANs)

- no DIMM data

System:

AMD EPYC 7251

ASRockRack EPYCD8-2T/Rev 2 (BIOS P2.50)

Windows 20H1 (19041.172)

Problem 1:

PCI Database problem - PCI\VEN_1022&DEV_145F is shown as "AMD K17 - Reserved" but it's the EPYC integrated XHCI

Problem 2:

The ASRockRack EPYC8D-2T(Rev 2) has onbaord IPMI based on ASPEED AST2500 but AIDA64 cant get any data from it

Problem 3:

AIDA64 wont display any FAN data from the sensor chip

Problem 4:

AIDA64 cant read DIMM Data (SPD)

1) We will fix it in the next AIDA64 beta update.

2) Please right-click on the bottom status bar of AIDA64 main window --> System Debug --> IPMI Access Dump. Copy-paste the full results into this topic, or attach the results as a TXT file to your post. You may need to enable status bar in AIDA64 / main menu / View first.

Also right-click on the bottom status bar of AIDA64 main window --> System Debug --> IPMI Dump. Copy-paste the full results into this topic, or attach the results as a TXT file to your post.

BTW, if you have a chance to install a Windows IPMI driver, that alone should solve this issue since then AIDA64 won't need to use low-level IPMI access.

3) Right-click on the bottom status bar of AIDA64 main window --> Sensor Debug --> ISA Sensor Dump. Copy-paste the full results into this topic, or attach the results as a TXT file to your post.

4) Your motherboad may use a SPD mux that is very difficult to handle without having the necessary technical details on the mux (provided by ASRock).  Let's check this first though: right-click on the bottom status bar of AIDA64 main window --> Sensor Debug --> SMBus Dump (Full).  Copy-paste the full results into this topic, or attach the results as a TXT file to your post.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...