Jump to content
AIDA64 Discussion Forum
Danil

Configuring Report Writing to SQL Database

Recommended Posts

 

 

Good day! I implement aida64be software for monitoring and collecting information in a domain. Set up a domain policy. The script looks like: / R / CSV / CUSTOM [\\ test-aida-001 \ C $ \ Shares \ AIDA64 \ aida64.rpf] / CSV2SQL [\\ test-aida-001 \ C $ \ Shares \ AIDA64] / ACCEPT / SAFE / SILENT. Reports to the database do not automatically fall. Have a name consisting of date and time. I do not see the name of the computer in the report. When loading reports into the database, I see only three tables. "Item", "ID", "Report". In the "Report" contains only a list of reports and all. The "Item" contains a detailed report, not the client PCs, but the server on which the AIDA64BE is installed. What am I not setting up or doing?

Edited by Danil
switch language

Share this post


Link to post
Share on other sites

You need to setup a database in File menu / Preferences / Database. More information about it:
https://www.aida64.co.uk/user-manual/database

Don't use the "[" and "]" characters and don't use spaces in the path, and you can't combine these commands, so you can use these one by one:
..\aida64.exe /R /CSV \\test-aida-001\C$\Shares\AIDA64\Reports\$HOSTNAME /CUSTOM \\test-aida-001\C$\Shares\AIDA64\aida64.rpf /ACCEPT /SAFE /SILENT
..\aida64.exe /CSV2SQL \\test-aida-001\C$\Shares\AIDA64\Reports /SAFE

Or use /DATABASE parameter instead of /CSV to create reports instantly to the database:
..\aida64.exe /R /DATABASE /CUSTOM \\test-aida-001\C$\Shares\AIDA64\aida64.rpf /ACCEPT /SAFE /SILENT

More about parameters: https://www.aida64.co.uk/user-manual/command-line-options

I can suggest for you our video tutorial and the description on the following link:
https://www.aida64.co.uk/knowledge-base/how-automatically-inventory-your-pcs-domain-using-gpo

 

Share this post


Link to post
Share on other sites
3 hours ago, Danil said:

Добрый день! Я внедряю программное обеспечение aida64be для мониторинга и сбора информации в домене. Настройте политику домена. Скрипт выглядит так: / R / CSV / CUSTOM [\\ test-aida-001 \ C $ \ Shares \ AIDA64 \ aida64.rpf] / CSV2SQL [\\ test-aida-001 \ C $ \ Shares \ AIDA64] / ПРИНЯТЬ / БЕЗОПАСНЫЙ / ТИХИЙ. Отчеты в базу данных не попадают автоматически. Иметь имя, состоящее из даты и времени. Я не вижу имя компьютера в отчете. При загрузке отчетов в базу данных я вижу только три таблицы. «Товар», «Удостоверение личности», «Отчет». В «Отчете» содержится только список отчетов и все. «Элемент» содержит подробный отчет не о клиентских ПК, а о сервере, на котором установлен AIDA64BE. Что я не настраиваю или не делаю?

Please post your questions and issues in English if possible.

Share this post


Link to post
Share on other sites
On 2/28/2019 at 10:55 AM, Danil said:

Good day! I implement aida64be software for monitoring and collecting information in a domain. Set up a domain policy. The script looks like: / R / CSV / CUSTOM [\\ test-aida-001 \ C $ \ Shares \ AIDA64 \ aida64.rpf] / CSV2SQL [\\ test-aida-001 \ C $ \ Shares \ AIDA64] / ACCEPT / SAFE / SILENT. Reports to the database do not automatically fall. Have a name consisting of date and time. I do not see the name of the computer in the report. When loading reports into the database, I see only three tables. "Item", "ID", "Report". In the "Report" contains only a list of reports and all. The "Item" contains a detailed report, not the client PCs, but the server on which the AIDA64BE is installed. What am I not setting up or doing?

In your custom report file (aida64.rpf) you always need to enable the Computer / Summary page. So the RPF file need to contain this line: InfoPage="Computer;Summary"
Also check your Preferences / Summary page and make sure that the "Computer Name" is enabled.

The "report" table contain the reports list. The "item" table contain the report details including the computer names. These tables linked through ID and ReportID columns.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×