Jump to content

Steelseries Apex 7 / TKL Keyboard LCD Unplug Issue


Michael O
 Share

Recommended Posts

Hello

I have aida64 set to output system info to the keyboards LCD panel which works fine. However, when I unplug the keyboard and re-connect the LCD panel does not display the AIda64 LCD panel anymore it defaults to steelseries logo. I then need to quit aida64 and reload it for the lcd panel to display. Is this expected behaviour?

Link to comment
Share on other sites

2 hours ago, Michael O said:

Hello

I have aida64 set to output system info to the keyboards LCD panel which works fine. However, when I unplug the keyboard and re-connect the LCD panel does not display the AIda64 LCD panel anymore it defaults to steelseries logo. I then need to quit aida64 and reload it for the lcd panel to display. Is this expected behaviour?

No, it's not, since the SteelSeries LCD module supports hot-plug.  Do you have other SteelSeries-made USB devices connected perhaps?

Link to comment
Share on other sites

I tried on another machine and the same issue occurs. The steelseries software profile loads, keyboard works, aida64 lcd works, reinsert the keyboard and the keyboard lights up, steelseries software profile loads but the aida64 lcd does not, i only get the steelseries logo on the lcd. The only way to get the lcd to show up is by restarting aida64.

Link to comment
Share on other sites

On 3/4/2021 at 9:28 AM, Michael O said:

I tried on another machine and the same issue occurs. The steelseries software profile loads, keyboard works, aida64 lcd works, reinsert the keyboard and the keyboard lights up, steelseries software profile loads but the aida64 lcd does not, i only get the steelseries logo on the lcd. The only way to get the lcd to show up is by restarting aida64.

Thank you!  In order to accelerate fixing this bug, I've sent you an email about this.

Link to comment
Share on other sites

1 minute ago, Michael O said:

Thanks. Just tried it and it works. You and the team are amazing!

Thank you for your help!  The fix will be added to the next AIDA64 beta update.  As it turns out, a similar bug plagued the Elgato and EVGA LCD modules as well, so we've fixed all three at once :) 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...