Jump to content

Degree symbol (°) is shown as � on RemoteSensor LCD, but not in preview


Recommended Posts

After reinstalling Windows 10 my RemoteSensor LCD panel is showing degree symbols (°) as a question mark (�) on any device that accesses the web page.
It is shown correctly in the AIDA64 LCD Items preview. But on my phone, Raspberry Pi, and even a browser on the same computer AIDA64 is running it's shown as the above question mark.

The raspberry pi and computer have the correct font installed, and where I can change character encoding it's set to automatic or UTF-8.
My Windows is set up to use English (UK) with Swedish input, region, and regional format.

Have I missed something in some setup somewhere?

Link to post
Share on other sites
  • 2 weeks later...
On 3/19/2021 at 10:15 AM, cadiremar said:

After reinstalling Windows 10 my RemoteSensor LCD panel is showing degree symbols (°) as a question mark (�) on any device that accesses the web page.
It is shown correctly in the AIDA64 LCD Items preview. But on my phone, Raspberry Pi, and even a browser on the same computer AIDA64 is running it's shown as the above question mark.

The raspberry pi and computer have the correct font installed, and where I can change character encoding it's set to automatic or UTF-8.
My Windows is set up to use English (UK) with Swedish input, region, and regional format.

Have I missed something in some setup somewhere?

Did it work properly before the reinstallation?

Link to post
Share on other sites
  • 2 weeks later...
On 3/29/2021 at 6:33 PM, cadiremar said:

Yes. It useed to work fine when viewed on both phone (albeit with the wrong font as I hadn't installed it there), Raspberry Pi, and browser on the same computer AIDA64 was installed on.

Maybe the issue is the ANSI (non-Unicode) codepage you have selected in the Windows Regional settings?

Link to post
Share on other sites

Huh. Changing "English (Sweden)" to "English (United Kingdom)" under the Regional Format settings in Win 10 solved it.
Must have had UK selected in the previous install. Can't hurt to keep it that way, as both long and short date and time format is the same in both places.

Thanks for pointing me in the right direction!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...