Jump to content

AIDA64 v2.20.1800 GPU Stability Test observations (EVGA GTX580)


Recommended Posts

I don't know if these are bugs or intended features but I tried the new version this morning and this is what happened.

In the System Stability Test I checked the new GPU test and ran it. GPU Clock, Shader Clock & Memory Clock on my EVGA GTX580 maxed out as expected. And temperature went up accordingly.

I then unchecked the GPU test to run only the CPU & FPU tests and the GPU test still runs. Then I noticed that the GPU clocks (GPU, Shader & Memory) do not return to idle speeds until AIDA64 is shut down. So I thought maybe that was making me think the GPU test was running.

I rebooted and started AIDA64 and everything looked normal. I ran the Stability test again with the GPU test unselected and the GPU test ran anyway or at least the clocks speeds all maxed out and temperature started going up. I did this several times to make sure but it always happens.

I went back to version 2.00 because I don't want the GPU test running with the CPU test even if it's not really running but just increasing the GPU clocks. But is this normal?



Edited by FrankD3
Link to comment
Share on other sites

nVIDIA GPU clock settings are switched to 3D profile the first time AIDA64 detects the installed GPUs. So it's normal to have the clocks switched to high values once, but the driver (ForceWare) should restore the settings once the GPU is not under load. If you untick the GPU test during a stress test session, the log window should display "GPU1: Finished", and the video card shouldn't be under load anymore. You can check the GPU utilization on the Display / GPU page.

If you don't want AIDA64 to switch to 3D profile, then you need to disable the option "Change to 3D profile on nVIDIA video adapters" in AIDA64 / main menu / File / Preferences / Stability.

Please let me know if you find any issues about clocks or a stuck GPU stress test even after disabling the mentioned option.



Link to comment
Share on other sites

I am noticing similar behavior with the 2.20.1800.

I ran the GPU test (only, all other stress test options unchecked), for about fifteen minutes.

I monitored the temperatures on my two GTX460 cards (SLi), seeing ~76° for the #1 (top) card and ~74° for the #2 (bottom) card.

I pressed the Stop button on the Stress Testing GUI, and the test stopped.

However, while the #2 card clocks went back to normal idle speeds, the #1 card clocks remained at 3D (full) speeds.

I also noticed that the #2 card temperature dropped back to what it normally is at idle, ~36°, the #1 card only dropped to ~55°, where it is normally at ~40° when idling.

I am using Forceware 285.58.

If I may provide further information, please do not hesitate to ask.


Link to comment
Share on other sites

Thank you for the feedback. But actually, the clocks do not reflect a stuck GPU stress test thread. The only sure verification is checking the GPU usage on the Display / GPU page. The clocks may be kept at high values (3D profile) by the ForceWare driver due to a driver bug. Please let me know if not only the clocks, but also the GPU usage gets stuck at a high value.



Link to comment
Share on other sites

We've done some test runs on our own GeForce cards, and what we've found out is that ForceWare video driver apparently "forgets" to restore the clocks according to the 2D (power-saving) profile after the OpenCL GPGPU SST is finished. We've verified whether AIDA64 properly de-initializes and frees up all used OpenCL objects, and then unloads OpenCL DLL as well, but everything works as it is supposed to. On AMD Radeon cards and AMD APUs there're no such issues. We've also verified the GPU usage, and it gets back to cca. 0% after the GPGPU SST session finished. Hence the thread doesn't get stuck, and the GPU is not loaded at all. The higher temperatures are simply due to ForceWare keeping the 3D clocks profile in place until the application (AIDA64.EXE) is running.

Link to comment
Share on other sites

Fiery, Thanks for that update. In just a little while I'll do some more testing now that you explained that the clocks are left in 3D but the test is not running. I didn't know how to verify that myself.

Using GPU-Z, which has a new test that puts the clocks in 3D mode, the clocks get reset automatically upon completion but that's not an OpenCL test as far as I know. In fact until now I didn't understand the difference :)

So thank you for explaining it.

Link to comment
Share on other sites

After more testing I have more detailed observations.

Activating the CPU/FPU stress test (with the GPU test UNCHECKED) increases the GPU clocks to 3D speeds and they never come back down during the test. The preference for "Stability: Change to 3D profile on nVIDIA video adapters" has absolutely no effect on this condition. Switching that on or off seems to have no effect at all. I watched the GPU usage and it never showed any activity so I know the GPU test doesn't run until it's selected to run. However, I was surprised to see the clocks revert back to 2D when the CPU test was cancelled. Also the GPU temperature never went higher than about 50 degrees C.

I then selected and ran the GPU test along with the CPU test. GPU usage went up as expected and the temperature went much higher to 65 degrees C. I then unchecked the GPU test and noticed that the log said GPU1 finished. The usage went down but the clocks stayed up and never came down. I then quit the test and the clocks never came down. But as soon as I quit AIDA64 the clocks immediately started coming down as observed with GPU-Z. I immediately started AID64 back up before the clocks got all the way back down and the clocks remained declining to 2D speeds.

Why does quitting AIDA64 allow the clocks to return to 2D?

I'm still using the GeForce version 275.33.

I hope this helps somehow.

PS - I repeated these tests several times to make sure the results were always the same.

Edited by FrankD3
Link to comment
Share on other sites

Further observations:

I opened two instances of GPU-Z 0.5.8 (one for each card) to monitor the frequency and usage.

Starting with a baseline of 50.6 MHz and 0% usage on both cards, I started AIDA64 and opened the System Stability Test GUI.

I unchecked all the tests.

I then checked only the CPU test and pressed Start.

Both cards frequency went to 797.3 MHz (I have them clocked at 800MHz), After a minute or so, the #2 (bottom) card went back to 50.6 MHZ, but the #1 card remained at 797.3 MHz. The GPU load remained at 0% for both cards, according to both AIDA64 and GPU-Z.

When I stopped the CPU Test, the #1 card returned to 50.6 MHz.

I then unchecked Stress CPU and checked Stress FPU.

I ran the Stress FPU test.

The results were the same.

I repeated this for all the stress tests, running each individually.

The Stress GPU test was the only one where the #1 card did not return to 50.6 MHz when the test was stopped, although the #2 card did, as before. I verified that the GPU was at 0% using both AIDA64 and GPU-Z.

Upon closing the AIDA64 application, the #1 card returned to 50.6 MHz.

Hopefully this might help you.

Also, given the issues nVIDIA has been having with drivers lately, it is no suprise to me that the nVIDIA driver is the cause of the problem.

Link to comment
Share on other sites

Thank you for the tests and your feedbacks. We've done more test runs today on various GeForce cards, and came up with a potential solution to this issue. Please upgrade to the latest beta version of AIDA64 Extreme Edition available at:


After upgrading to this new version, make sure to restart Windows to finalize the upgrade.

Let me know how it works. Please note that by simply unclicking the GPU test while running the SST, the clocks will not return to 2D profile, since unticking a subtest only suspends it, and the OpenCL session is not freed up. Only when you stop SST via the Stop button will the clocks return to 2D profile.

With Radeon GPUs the clock management doesn't depend on an existing OpenCL session, but apparently it is simply based on GPU utilization. So when AIDA64 stops stressing a Radeon, the clocks will return to their 2D settings. While on GeForce GPUs you have to free up the OpenCL session to make ForceWare recognize that the GPU is not under stress anymore.

Link to comment
Share on other sites

I just finished testing v2.20.1803 beta and all is well. The clocks return to 2D immediately after stopping the stress test. There is no need to quit AIDA64 anymore. And more importantly to me, the clocks do not switch to 3D when simply running the CPU test. Unchecking the gpu test while running the SST functions exactly as you describe above.

Another job well done! It amazes me how fast you respond to problems and fix them. Thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...