Jump to content
AIDA64 Discussion Forum
CopperMich

Not Working Anymore On G510

Recommended Posts

Hello,

Recently installed new logitech gaming software for G510.

Aida always worked , now i cant get the error away when i activate the lcd support.

Cannot get to the settings to configure the temps to display on the keyboard.

Logitech gaming soft 8.20.74

does anyone have the same prob?

Share this post


Link to post
Share on other sites

1) Do you use Windows 7 64-bit?

2) Did you have a previous version of Logitech LCD drivers installed before installing v8.20? Did AIDA64 work properly before installing v8.20?

Thanks,

Fiery

Share this post


Link to post
Share on other sites

I have got the same problem with logitech gaming software 8.20.74

The software ran fine before the update.

When i go on preference:

aida.gif

Im using the Trial version on x64 Computer.

If the problem fix

I'll buy AIDA64 today because it is really good.

Sorry for my bad english.

Share this post


Link to post
Share on other sites

There seems to be a bug in Logitech Gaming Software under Windows 8 that sometimes prevents AIDA64 from detecting the connected devices.  We'll do more test runs with the latest Logitech Gaming Software, and will try to come up with a workaround until Logitech could fix it from their end.

Share this post


Link to post
Share on other sites

I am running Windows 7 64 bit.  I also have the problem that when enabling Logitech's LCD under Aida64 I get the error "LCD Init Failed."  However I just noticed that another non-Logitech applet for the LCD screen for a game is also no longer displaying on the LCD screen even though its applet is checked in Logitech's Gaming Software.  I have tried uninstalling the version I had (lgs840 64) and re-installing the latest version (lgs846 64) and still not applets besides those included in the Logitech bundle will appear.  Anyone have an idea of what I am missing?  Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...