Jump to content

Aquasuite X57 slows down AIDA64 sensors reading


Recommended Posts

As title says...

At certain day I've noticed that even at 5000 ms (500 ms was a typo) sensors update frequency settings AIDA64 (I'm using 6.75.6100) did update reading like once a minute and even initial load after Windows start takes much more time than usual.

It took me a few hours to find out that it has happened after I've updated Aquasuite from version X.53 to X.57. It has been confirmed by myself a few times by restoring Windows 11 from the image with version X.53 installed (where reading updates are done according to the settings) and applying the update to X.57 which immediately slows it down substantially.

I guess not many people use this combination (AIDA64 and Aquasuite) but still this is an issue.

Fierry, I guess you have contacts at Aqua Computer - could you please check what has changed from 53 to 57. As a side note - I skip X.54, X.55 and X.56, there is a chance the changes were done prior to X.57...

Thanks!

Link to comment
Share on other sites

There is a thread on the Aquacomputer German forum about the recent firmware update to the D5 Next causing AIDA to no longer read the D5 Next data properly. Aquacomputer said that they made some minor changes to the USB protocol. They did not offer any details and said that if the D5 Next works with Aquasuite properly that is all they are worried about and AIDA will need to update their program. I don't know if this is related to the issue you are having.

If you don't speak German just right click and select Translate into English (in Chrome anyway).

LINK

Edit to add - For some reason, when I posted this, it shows up in Red and says Hidden. Not sure why.

Edited by SpeedyV
Hidden Post?
Link to comment
Share on other sites

When I saw the posts about AIDA64 and the D5 Next with the X.57 update not working I checked what happened with my SIV utility and it worked with the 1024 firmware.

When I looked further the Input Length has changed from 151 to 162 so my guess is that AIDA64 assumes it's 151 whereas SIV uses the input length from HIDP_CAPS->InputReportByteLength. Given this I suspect AIDA64 should be updated to do similar for the D5 Next and all similar devices.

AFAIK none of the offsets in the first 151 bytes have changed and assume new items have been added in the extra 11 bytes.

When I looked at the AIDA64 dump it totally failed to dump the D5 Next data so I felt I would also attach the SIV dump.

D5 Next.png

D5 Next.txt

Link to comment
Share on other sites

8 hours ago, SirioGala said:

Hello,

i have same combo.

I've update to x.57 and also updated d5 next firmware and now i'm not gettin' water temp value in aida anymore.

Sometime ago, after yet another aquasuite update (with some microcode update, at least for my QUADRO and OCTO) AIDA64 stopped its reading for some Aqua sensors. It has been fixed by AIDA64 great team by updating this wonderful program.

I would suggest you start another thread and attach your sensor debug information to your post.

Good luck!

Link to comment
Share on other sites

I posted some info in this thread yesterday about a post I saw on another forum about this subject. For some reason, my post is highlighted and says "Hidden". I have no idea why and have reported the post to the mods asking them if my post violated a forum rule. My account is fine and I have never had a post show up as Hidden before. I did mention another company since this thread is about AIDA reading data from devices manufactured by another company. The company I mentioned is not a competitor of ADIA. I am making this post with no mention of another company as a test to see if it also shows up as Hidden. Does anyone know why a post would be Hidden?

Link to comment
Share on other sites

I posted 23 hours ago with my analysis of the D5 Next change and this also got hidden. Do I need to do anything to get a moderator to look at it?

I also posted this on the Aquacomputer forum

Just now I posted this with a hot link and it also got hidden

Link to comment
Share on other sites

On 8/12/2022 at 4:40 PM, Elderdeekey said:

As title says...

At certain day I've noticed that even at 500 ms sensors update frequency settings AIDA64 (I'm using 6.75.6100) did update reading like once a minute and even initial load after Windows start takes much more time than usual.

It took me a few hours to find out that it has happened after I've updated Aquasuite from version X.53 to X.57. It has been confirmed by myself a few times by restoring Windows 11 from the image with version X.53 installed (where reading updates are done according to the settings) and applying the update to X.57 which immediately slows it down substantially.

I guess not many people use this combination (AIDA64 and Aquasuite) but still this is an issue.

Fierry, I guess you have contacts at Aqua Computer - could you please check what has changed from 53 to 57. As a side note - I skip X.54, X.55 and X.56, there is a chance the changes were done prior to X.57...

Thanks!

We've pinged Aquasuite about this issue.

Link to comment
Share on other sites

On 8/13/2022 at 6:41 AM, SirioGala said:

Hello,

i have same combo.

I've update to x.57 and also updated d5 next firmware and now i'm not gettin' water temp value in aida anymore.

Please right-click on the bottom status bar of AIDA64 main window --> Sensor Debug --> Aqua Computer Dump. Copy-paste the full results into this topic, or attach the results as a TXT file to your post. You may need to enable status bar in AIDA64 / main menu / View first.


Thanks,
Fiery

Link to comment
Share on other sites

Fiery, in my attempt to help with resolution of this issue I'm attaching 2 dump files here - one with Aquasuite X.53 installed (where there is no troubles with AIDA64 sensor readings) and with Aquasuite X.57 installed (where there is substantial delay between sensors readings).

Simple comparison these 2 files with WinMerge program clearly shows there are difference in MPS, OCTO and QUADRO areas.

Thanks again!

aquacomputerdump-X53.txt aquacomputerdump-X57.txt

Link to comment
Share on other sites

On 8/12/2022 at 3:40 PM, Elderdeekey said:

I've noticed that even at 500 ms sensors update frequency

I suspect it's impossible for any utility to update Aqua Computer sensors every 500 ms as when I was adding Octo support to SIV I noted that it typically takes about 0.972 seconds to read the Octo sensor block! The D5 Next is about 0.369 seconds both of which are way longer than other none Aqua devices.

The AIDA64 dumps don't seem to report the read time, should they ?, I expect they will be similar.

0.972 seconds to read the Octo sensor block.png

Link to comment
Share on other sites

On 8/14/2022 at 9:57 AM, red-ray said:

I posted 23 hours ago with my analysis of the D5 Next change and this also got hidden. Do I need to do anything to get a moderator to look at it?

I also posted this on the Aquacomputer forum

Just now I posted this with a hot link and it also got hidden

unfortunately we need some strict rules to fight with spam, we are continuously tune the settings to make it less annoying.

Link to comment
Share on other sites

On 8/14/2022 at 4:59 PM, Elderdeekey said:

Fiery, in my attempt to help with resolution of this issue I'm attaching 2 dump files here - one with Aquasuite X.53 installed (where there is no troubles with AIDA64 sensor readings) and with Aquasuite X.57 installed (where there is substantial delay between sensors readings).

Simple comparison these 2 files with WinMerge program clearly shows there are difference in MPS, OCTO and QUADRO areas.

Thanks again!

aquacomputerdump-X53.txt 12.43 kB · 4 downloads aquacomputerdump-X57.txt 12.43 kB · 5 downloads

Thank you for your help!  We've fixed sensor support for D5 Next with its latest firmware update.  Make sure to upgrade to the latest beta version of AIDA64 Extreme available at:

https://www.aida64.com/downloads/latesta64xebeta

After upgrading to this new version, make sure to restart Windows to finalize the upgrade.

Let us know how it works ;)

Link to comment
Share on other sites

2 hours ago, Fiery said:

Thank you for your help!  We've fixed sensor support for D5 Next with its latest firmware update.  Make sure to upgrade to the latest beta version of AIDA64 Extreme available at:

https://www.aida64.com/downloads/latesta64xebeta

After upgrading to this new version, make sure to restart Windows to finalize the upgrade.

Let us know how it works ;)

Nope :(((

As soon as I applied X.57 update to Aquasuite and installed AIDA64 6115 beta its sensor updates (via gadget) again became very slow... Attached dump is from such system...

aquacomputerdump6115.txt

Link to comment
Share on other sites

14 hours ago, Elderdeekey said:

Nope :(((

As soon as I applied X.57 update to Aquasuite and installed AIDA64 6115 beta its sensor updates (via gadget) again became very slow... Attached dump is from such system...

aquacomputerdump6115.txt 12.42 kB · 0 downloads

Aqua Computer said their devices have a 1 second report update rate, and that could indeed slow our sensor module down, especially if you have multiple Aqua Computer devices attached to your system.

Link to comment
Share on other sites

Fiery, I'm a bit lost...

Does Aqua message mean that they've changed update rate in X.57 (or at least after X.53 as I didn't install 54-56)?

The reason to be lost is that with the same AIDA64 update frequency - 5000ms - I have no troubles with sensors reading with X.53 installed. Immediately after X.57 installation AIDA64 (even your latest beta) with the same settings (I do not change even a single bit in settings) becomes extremely slow and barely reads sensors (it looks to me like once every 15-30 seconds or alike)...

Link to comment
Share on other sites

3 minutes ago, Elderdeekey said:

Fiery, I'm a bit lost...

Does Aqua message mean that they've changed update rate in X.57 (or at least after X.53 as I didn't install 54-56)?

The reason to be lost is that with the same AIDA64 update frequency - 5000ms - I have no troubles with sensors reading with X.53 installed. Immediately after X.57 installation AIDA64 (even your latest beta) with the same settings (I do not change even a single bit in settings) becomes extremely slow and barely reads sensors (it looks to me like once every 15-30 seconds or alike)...

Quite frankly I have no idea what Aqua Computer did to their software.  What they said about the current 1 second update rate is the current situation.  I don't know if this is a newly introduced limitation or it's always been like that...

Link to comment
Share on other sites

On 8/17/2022 at 10:28 AM, Fiery said:

Aqua Computer said their devices have a 1 second report update rate, and that could indeed slow our sensor module down, especially if you have multiple Aqua Computer devices attached to your system.

This is the aquacomputer thread https://forum.aquacomputer.de/berwachung-und-steuerung/112725-aquero-aquasuite-verursachen-eine-viel-zu-hohe-latenz-updatefrequenz-sensorprotokollierung/?s=84986946d05eb2e855ba490373a93ca161d993f1

The guys from aquacomputer say, it is the method of AIDA, how the provided aquacomputer-data (1 second update rate) is being processed by AIDA. They say, that this method causes delays with AIDAs update frequency.

They assume AIDA is holding sensor data (CPU, GPU, RAM, ...) until the next sensor data update is coming from aquacomputer. This holding should be removed or should be changed in a way, so that there are no delays anymore.

Link to comment
Share on other sites

Interesting!

Could you please ask Aqua folks via forum (I do not know German) -

WHY everything goes smoothly with Aida64 sensor reading when Aquasuite X.53  is installed
and
as soon as it is updated to version X.57  Aida64 reading becomes extremely slow?! (Indeed it is the same PC/OS/Aida64 version with the same settings.)

In my humble opinion something has been changed by Aquasuite programmers in between (could be in v. 54, 55, 56 or 57).

Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...