Jump to content

Corsair Link Support

Michael O

Recommended Posts

It seems this is an issue that plagues AX1200i PSUs, but it still works properly with AX760i. AX1200i seems to report 0 Ampers and 0 Watts for the +5V and +3.3V rails in many cases, and that prevents AIDA64 from calculating the total PSU power draw. We'll have to gather more feedbacks on other AXi Series PSUs to see what's going on. It would be interesting to see if Corsair Link software can show a stable power draw reading for all voltage rails on AX1200i...

Link to comment
Share on other sites

Hi Fiery,


Regarding AX1200i, I confirm everything you say in your « theory Â», observed via CorsairLink : all voltages rock stable, amperage varying (which may not be abnormal) but 5 V starts at 0.00 A for a few minutes then « takes off Â», 3.3 V stays at 0.00 A and doesn’t seem to take off at all in CL except occasionally. For the +5 V and +12 V there is the occasional 0.00 A reading but it tends to stay at a realistic value. Opening Aida64 will detect those sensors right away and report them at the same levels (can’t check real time but seems close enough) ; it will require almost 10 minutes to add (automatically) the +3.3 V sensor (Amps) to the list but then it seems to stay at correct values.


So it’s probably hardware-related, I thought maybe the PSU needed to warm up before the chip can correctly report values, but that seemed a bit strange to me though and repeating the process yields the same results… even warm CL will report 0.00 A on the +3.3 V, and Aida64 will require again another 10-20 minutes to start reporting values for the 3.3 V rail…


Not sure what to think at this point, but on my side it doesn’t seem to be an issue that Aida64 can easily address, if at all. It seems I just have to wait some minutes and it will eventually appear...


Edit :I can confirm once the +3.3 V current becomes displayed in Aida64, it stays there with measured values for hours (until the next close / open of Aida64)

Link to comment
Share on other sites

wow., Yep, just checked with the newest Corsair LInk (v4) and sure enough 3.3 and 5.0 report as zero - This would also explain why it suddenly stops working. 


Thanks for the help here. At least the 12v rail and the CPU package report wattage still - Those are primarily what I am trying to monitor and +/- 20W from the missing 5.0/3.3 rails really isnt that crucial. 

Link to comment
Share on other sites

  • 2 weeks later...
Running an Corsair AX1200i and an HT115 with Corsair link  Both devices show in the sensors page but then the fans on the HT115 start to surge from 900 rpm to 1200 rpm every few seconds.. this usually corresponds to the devices dropping from the Sensor page.

------[ AIDA64 Extreme v5.60.3761 Beta ]------
------[ Microsoft Windows 10 Pro 10.0.10586.104 (64-bit) ]------
------[ Motherboard Info ]------
Motherboard ID      : 63-0100-000001-00101111-010914-Chipset$0AAAA000_BIOS DATE: 12/18/15 23:23:06 VER: 05.06.05
Motherboard Model   : Asus Rampage V Extreme
Motherboard Chipset : Intel Wellsburg X99, Intel Haswell-E
DMI MB Version      : Rev 1.xx
DMI MB Serial       : 150850899700241
DMI SYS Manufacturer: ASUS
DMI SYS Product     : All Series
DMI SYS Version     : System Version
DMI SYS Serial      : System Serial Number
DMI BIOS Version    : 1902

------[ DevClass / Human Interface Devices ]------
<DESC>HID Keyboard Device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_00#8&1bcf676c&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_00\8&1BCF676C&0&0000</INSTANCE><BUSNUM>00000007</BUSNUM><ADDR>00000003</ADDR>
<DESC>HID-compliant game controller</DESC><DEVPATH>\\?\hid#vhidjs#9&350cc7a5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VHIDJS\9&350CC7A5&0&0000</INSTANCE><BUSNUM>00000006</BUSNUM><ADDR>00000001</ADDR>
<DESC>Razer Mamba</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_01&col01#8&c5a33ad&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_01&COL01\8&C5A33AD&0&0000</INSTANCE><BUSNUM>00000004</BUSNUM><ADDR>00000003</ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_01&col02#8&40bdb27&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_01&COL02\8&40BDB27&0&0001</INSTANCE><BUSNUM>00000008</BUSNUM><ADDR>00000004</ADDR>
<DESC>Razer Orbweaver Chroma</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_00#8&25225433&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_00\8&25225433&0&0000</INSTANCE><BUSNUM>00000000</BUSNUM><ADDR>00000001</ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_01&col02#8&14b1671&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_01&COL02\8&14B1671&0&0001</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000002</ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_046d&pid_0a5b&mi_03&col01#9&2d965b66&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_046D&PID_0A5B&MI_03&COL01\9&2D965B66&0&0000</INSTANCE><BUSNUM>0000000A</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID Keyboard Device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_02#8&3031716f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_02\8&3031716F&0&0000</INSTANCE><BUSNUM>00000005</BUSNUM><ADDR>00000004</ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_01&col02#8&c5a33ad&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_01&COL02\8&C5A33AD&0&0001</INSTANCE><BUSNUM>00000004</BUSNUM><ADDR>00000003</ADDR>
<DESC>HID-compliant system controller</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_01&col03#8&40bdb27&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_01&COL03\8&40BDB27&0&0002</INSTANCE><BUSNUM>00000008</BUSNUM><ADDR>00000004</ADDR>
<DESC>HID-compliant phone</DESC><DEVPATH>\\?\hid#vid_046d&pid_0a5b&mi_03&col02#9&2d965b66&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_046D&PID_0A5B&MI_03&COL02\9&2D965B66&0&0001</INSTANCE><BUSNUM>0000000A</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID-compliant system controller</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_01&col03#8&14b1671&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_01&COL03\8&14B1671&0&0002</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000002</ADDR>
<DESC>HID-compliant vendor-defined device</DESC><DEVPATH>\\?\hid#vid_046d&pid_0a5b&mi_03&col03#9&2d965b66&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_046D&PID_0A5B&MI_03&COL03\9&2D965B66&0&0002</INSTANCE><BUSNUM>0000000A</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID-compliant vendor-defined device</DESC><DEVPATH>\\?\hid#vid_046d&pid_0a5b&mi_03&col04#9&2d965b66&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_046D&PID_0A5B&MI_03&COL04\9&2D965B66&0&0003</INSTANCE><BUSNUM>0000000A</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID-compliant system controller</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_01&col03#8&c5a33ad&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_01&COL03\8&C5A33AD&0&0002</INSTANCE><BUSNUM>00000004</BUSNUM><ADDR>00000003</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_01&col04#8&40bdb27&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_01&COL04\8&40BDB27&0&0003</INSTANCE><BUSNUM>00000008</BUSNUM><ADDR>00000004</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_01&col04#8&14b1671&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_01&COL04\8&14B1671&0&0003</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000002</ADDR>
<DESC>Razer Mamba</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_00#8&241dbff2&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_00\8&241DBFF2&0&0000</INSTANCE><BUSNUM>00000003</BUSNUM><ADDR>00000002</ADDR>
<DESC>HID-compliant consumer control device</DESC><DEVPATH>\\?\hid#vid_041e&pid_4099&mi_03&col01#9&3616d512&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_041E&PID_4099&MI_03&COL01\9&3616D512&0&0000</INSTANCE><BUSNUM>0000000B</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID-compliant headset</DESC><DEVPATH>\\?\hid#vid_041e&pid_4099&mi_03&col02#9&3616d512&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_041E&PID_4099&MI_03&COL02\9&3616D512&0&0001</INSTANCE><BUSNUM>0000000B</BUSNUM><ADDR>00000005</ADDR>
<DESC>Razer BlackWidow Chroma</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_02#8&254c8902&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_02\8&254C8902&0&0000</INSTANCE><BUSNUM>00000009</BUSNUM><ADDR>00000005</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_01&col04#8&c5a33ad&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_01&COL04\8&C5A33AD&0&0003</INSTANCE><BUSNUM>00000004</BUSNUM><ADDR>00000003</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_01&col05#8&40bdb27&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_01&COL05\8&40BDB27&0&0004</INSTANCE><BUSNUM>00000008</BUSNUM><ADDR>00000004</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_01&col05#8&14b1671&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_01&COL05\8&14B1671&0&0004</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000002</ADDR>
<DESC>HID-compliant device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0046&mi_01&col05#8&c5a33ad&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0046&MI_01&COL05\8&C5A33AD&0&0004</INSTANCE><BUSNUM>00000004</BUSNUM><ADDR>00000003</ADDR>
<DESC>Razer Orbweaver Chroma</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_02#8&228c2751&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_02\8&228C2751&0&0000</INSTANCE><BUSNUM>00000002</BUSNUM><ADDR>00000003</ADDR>
<DESC>Razer BlackWidow Chroma</DESC><DEVPATH>\\?\hid#vid_1532&pid_0203&mi_01&col01#8&40bdb27&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0203&MI_01&COL01\8&40BDB27&0&0000</INSTANCE><BUSNUM>00000008</BUSNUM><ADDR>00000004</ADDR>
<DESC>HID Keyboard Device</DESC><DEVPATH>\\?\hid#vid_1532&pid_0207&mi_01&col01#8&14b1671&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}</DEVPATH><INSTANCE>HID\VID_1532&PID_0207&MI_01&COL01\8&14B1671&0&0000</INSTANCE><BUSNUM>00000001</BUSNUM><ADDR>00000002</ADDR>
------[ DevClass / USBXpress Devices ]------
<DESC>Corsair Hydro Series 7289 USB Device</DESC><DEVPATH>\\?\usb#vid_1b1c&pid_0c0a#7289_2.0#{3c5e1462-5695-4e18-876b-f3f3d08aaf18}</DEVPATH><INSTANCE>USB\VID_1B1C&PID_0C0A\7289_2.0</INSTANCE><BUSNUM>00000000</BUSNUM><ADDR>0000000B</ADDR>
<DESC>Corsair Link USB Dongle</DESC><DEVPATH>\\?\usb#vid_1b1c&pid_1c00#r45k0661#{3c5e1462-5695-4e18-876b-f3f3d08aaf18}</DEVPATH><INSTANCE>USB\VID_1B1C&PID_1C00\R45K0661</INSTANCE><BUSNUM>00000000</BUSNUM><ADDR>0000000C</ADDR>
< No Corsair Link Device Found >
Link to comment
Share on other sites

Running an Corsair AX1200i and an HT115 with Corsair link  Both devices show in the sensors page but then the fans on the HT115 start to surge from 900 rpm to 1200 rpm every few seconds.. this usually corresponds to the devices dropping from the Sensor page.

Try to set your configured fan duty cycle (%) in AIDA64 / main menu / File / Preferences / Hardware Monitoring / Set Asetek fan speed to avoid AIDA64 altering the fan duty cycle to maximum (100%).

Link to comment
Share on other sites

  • 2 weeks later...

Ok, I can see these under sensors and USB devices, but is there a Corsair page somewhere?


Can AIDA64  change fan speeds?


I have a h110i gtx unit and it shows the pump/fan speeds, but do not see a way to control them.


If I turn on Corsair link 3.x, the  pump/fan speed in aida64 show 0 on my sensor, on usb page, go away!


Also, set asetek fan speed to 50% 50%.  Why are there two percents there and it did not seem to change anything.


Did I miss something?

Link to comment
Share on other sites

There's no Corsair page specifically. And no, AIDA64 cannot control fan speed in general. The Asetek option in the Preferences is only a workaround, to avoid AIDA64 inadvertently altering the fan speed when reading out the actual fan RPM value. The Asetek option should work for H110i GTX, but not for non-Asetek-based water cooler solutions. The 2 percents are for the 2 fans of Asetek water coolers.

As for Corsair Link (CL), please note that for basically all Corsair PSUs and water cooler hardware, it's best to close Corsair's own software, since it would collide with the sensor code of AIDA64 (and other 3rd party software as well BTW). CL Software lacks the necessary SDK or API that would be used to properly synchronize a 3rd party software with CL Software. We and other developers keep asking Corsair to improve their software, but it hasn't worked out so far.

Link to comment
Share on other sites

so if I close down CL software, how do I control the fans?

The fans should still be spinning at the last setting. It's not our fault that CL Software cannot work with other software running in the same time ;)


SIV?  Can it run at same time as AIDA64?

Yes, it should work.

Link to comment
Share on other sites

no its not your fault, I do not mean that


I have the asetek 110i unit


I know the Coolit unit is better, and I have one sitting around


Can that one run with aida64 and cl software at same time?  Would it work any better with that unit?


My problerm is my fans come on higher when I do alot of video encodes, so I start CL so the fans speed up and aida64 loses the pump and fan speeds.  No big deal, but wanted to report

Link to comment
Share on other sites

Ok, so, since I will be replacing the Corsair stuff with another cooler, what do you recommend that doesn't interfere with your software and you support?

As far as I know, Aquacomputer offers Aqua Suite that works fine with AIDA64 and other monitoring software. But you should ask around in the enthusiasts users circles, because quite frankly, we're not experts of water-cooling here :) There may be other products around there that could fit the requirements.

Link to comment
Share on other sites

Ok, I am confused


Let me give you the string of events....


My win10 system has aida64, latest extreme beta (today), runs fine, runs lcd screen fine

I also had Cosairlink 3 installed, not running


Aida64 shows 110i-GTX pump and fan speeds, etc until I run Corsair link3, then Aida64 cannot find those 2 fields.  That is how it has been so thats ok


So today:


I uninstall Corsairlink3, then Reboot

Install Corsair link4/new driver/service



CL4 does not see any devices either

Aida64 cannot see the pump and fans either, even if CL4 is not running and driver not running


I uninstall CL4/driver



Aida64 still cannot see the Corsair H110i GTX unit

But interesting thing is SIV sees them just fine


I have attached the screen shot from SIV Cooling 'status' screen


Any ideas?  I am out of them!!!


edit--What I am doing now is running both SIV and AIDA64.  SIV seems to see the Corsair stuff and I am letting it handle the fan speed stuff based upon water temps......With some experimentation, my system idle water temp is 32C and when doing video encodes (hex cpu at almost 100%0, the water gets to 47C


So I am setting my temps/pwm for the fans in SIV accordingly and it works fine.  So I will use SIV in place of CL4 to control fans


My only problem is aida64 will no longer see the CL pump and fan, even with CL software/driver removed and I rebooted.  Do you know why?


Link to comment
Share on other sites

My only problem is aida64 will no longer see the CL pump and fan, even with CL software/driver removed and I rebooted.  Do you know why?

Please right-click on the bottom status bar of AIDA64 main window --> System Debug --> USB Dump. Copy-paste the full results into this topic, or attach the results as a TXT file to your post. You may need to enable status bar in AIDA64 / main menu / View first.



Link to comment
Share on other sites

Ok, I have attached the usb dump for you for the system that cannot see the corsair stuff


I see in the usb dump, it shows the Corsair, so I also enclosed the fan/pump section of variables for sensors for my lcd screen, which is missing these fields



Can aida64 and siv live running side-by-side?  I have gotten siv to run the pump/fan, so no need for CL4 or and corsair software - yay!



  • Like 1
Link to comment
Share on other sites

Thank you. I suppose the issue is that you've removed Corsair Link software, and it also removed the DLL file (called SiUSBXp.dll) that is necessary for AIDA64 to work properly with Asetek LC compatible devices. You need to either install the Corsair Link v4 software again, or get a 32-bit version of the mentioned DLL and copy it into AIDA64 installation folder. Please drop me a private message if you get into troubles getting that file, and I'll send it to you.

As for SIV and AIDA64, yes, they both use industry standard synchronization mutexes to make sure they can work together, handling the same devices without collisions. Generally speaking, 3rd party software are in most cases synchronized with each other. It's certain software made by big hardware companies that tend to lack the necessary synchronization.

Link to comment
Share on other sites

Does aida64 support the Commander Mini?


I plugged one in with a light strip and 4 temp sensors.   Aida64 doesn't see them  (SIV does, so I know they are connected correctly)

Yes, it does, but you first need to enable AIDA64 / main menu / File / Preferences / Stability / Corsair Link sensor support, and restart AIDA64.

Link to comment
Share on other sites

I was running aida64 and lost a sensor in the corsair screen again.  The sensor just disappeared.


I have a h110i-gtx and added a commander mini with 4 temp sensors, light panel


AIDA64 found all at first, but then lost the Fan speed on the h110i-gtx.  Pump speed and pump temp are there


Tried rebooting, still missing.   SIV shows the missing sensor.  I've enclosed their discovery too


I enclose a corsairlink dump




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...