Jump to content

fixed: Incorrect CPU usage since Windows 11 22H2

Go to solution Solved by Fiery,

Recommended Posts

Has anyone else experienced issues with their sensor panel not showing correct CPU usage since updating to the new Windows 11 version 22H2? Sensor panel constantly shows around 0-3% usage while task manager displays what I assume to be the correct percentage. Any feedback would be appreciated ! 

Link to comment
Share on other sites

On 10/27/2022 at 6:20 AM, Jethro said:

Same issue with AIDA64; however, open hardware monitor, Task Manager, SIV64, and AMD Ryzen Master are reporting correct values.  In addition, AIDA64 is reporting incorrect CPU Clock values as compared to the other previously mentioned software.

I can also confirm the incorrect CPU Clock values as well. Im on a 12900K and compared to Task Manager, etc. AIDA's reporting is all over the place. Also, I have just updated to the newest version 6.80.6200 with an build date of October 24th and still no change in either the CPU Usagge or CPU Clock values showing as incorrect...

Link to comment
Share on other sites

14 hours ago, Squall Leonhart said:

RTSS worked around it by using another cpu time counter, it is not fixed, only microsoft can fix it.


So why cant AIDA do this for the time being then? Its really quite annoying to have paid for this software just really to use the senbsor panel and for the panel to not be accurate... 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...